summaryrefslogtreecommitdiff
path: root/net-analyzer/ipband/ipband-0.8.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /net-analyzer/ipband/ipband-0.8.1-r2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'net-analyzer/ipband/ipband-0.8.1-r2.ebuild')
-rw-r--r--net-analyzer/ipband/ipband-0.8.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/ipband/ipband-0.8.1-r2.ebuild b/net-analyzer/ipband/ipband-0.8.1-r2.ebuild
new file mode 100644
index 000000000000..6d65e278291e
--- /dev/null
+++ b/net-analyzer/ipband/ipband-0.8.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A pcap based IP traffic and bandwidth monitor"
+HOMEPAGE="http://ipband.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=net-libs/libpcap-0.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-postfix.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin ipband
+ doman ipband.8
+ dodoc CHANGELOG README
+
+ newinitd "${FILESDIR}"/ipband-init ipband
+
+ insinto /etc/
+ newins ipband.sample.conf ipband.conf
+}