summaryrefslogtreecommitdiff
path: root/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild')
-rw-r--r--net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
new file mode 100644
index 000000000000..ba3c20d34201
--- /dev/null
+++ b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="display bandwidth usage on an interface"
+SRC_URI="http://www.ex-parrot.com/pdw/iftop/download/${P/_/}.tar.gz"
+HOMEPAGE="http://www.ex-parrot.com/pdw/iftop/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0_pre4-configure.ac.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-Makefile.am.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-tsent-set-but-not-used.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-ip6.arpa.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-fix-MAC-formatting.patch
+)
+S="${WORKDIR}"/${P/_/}
+
+src_prepare() {
+ default
+ # bug 490168
+ cat "${FILESDIR}"/ax_pthread.m4 >> "${S}"/acinclude.m4 || die
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin iftop
+ doman iftop.8
+
+ dodoc AUTHORS ChangeLog README "${FILESDIR}"/iftoprc
+}