summaryrefslogtreecommitdiff
path: root/net-analyzer/iftop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-19 20:11:46 +0000
commit5b5df25227111ef465caf5c52bcfb66dac3219cd (patch)
tree31b713cac6188358125cbb66b8804030328740f0 /net-analyzer/iftop/files
parent02e2208f46f4e2c00fb9743cbc47350bdd233bfa (diff)
gentoo resync : 19.01.2018
Diffstat (limited to 'net-analyzer/iftop/files')
-rw-r--r--net-analyzer/iftop/files/iftop-1.0_pre4-ip6.arpa.patch48
-rw-r--r--net-analyzer/iftop/files/iftop-1.0_pre4-pthread.patch46
-rw-r--r--net-analyzer/iftop/files/iftop-1.0_pre4-tinfo.patch55
3 files changed, 48 insertions, 101 deletions
diff --git a/net-analyzer/iftop/files/iftop-1.0_pre4-ip6.arpa.patch b/net-analyzer/iftop/files/iftop-1.0_pre4-ip6.arpa.patch
new file mode 100644
index 000000000000..706db4546db9
--- /dev/null
+++ b/net-analyzer/iftop/files/iftop-1.0_pre4-ip6.arpa.patch
@@ -0,0 +1,48 @@
+From 35af3cf65f17961d173b31fd3b00166ec095c226 Mon Sep 17 00:00:00 2001
+From: Paul Warren <pdw@mythic-beasts.com>
+Date: Mon, 6 Feb 2017 21:35:37 +0000
+Subject: [PATCH] Fix bug with DNS resolution. https://bugzilla.redhat.com/show_bug.cgi?id=1120254
+
+---
+ resolver.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/resolver.c b/resolver.c
+index adddbc1..a3123bd 100644
+--- a/resolver.c
++++ b/resolver.c
+@@ -438,11 +438,11 @@ void resolver_worker(void* ptr) {
+ char **ch_pp;
+ void **void_pp;
+ } u_old = { &old };
+- if(hash_find(ns_hash, &addr, u_old.void_pp) == HASH_STATUS_OK) {
++ if(hash_find(ns_hash, &addr.as_addr6, u_old.void_pp) == HASH_STATUS_OK) {
+ hash_delete(ns_hash, &addr);
+ xfree(old);
+ }
+- hash_insert(ns_hash, &addr, (void*)hostname);
++ hash_insert(ns_hash, &addr.as_addr6, (void*)hostname);
+ }
+
+ }
+@@ -488,7 +488,7 @@ void resolve(int af, void* addr, char* result, int buflen) {
+
+ pthread_mutex_lock(&resolver_queue_mutex);
+
+- if(hash_find(ns_hash, raddr, u_hostname.void_pp) == HASH_STATUS_OK) {
++ if(hash_find(ns_hash, &raddr->as_addr6, u_hostname.void_pp) == HASH_STATUS_OK) {
+ /* Found => already resolved, or on the queue, no need to keep
+ * it around */
+ free(raddr);
+@@ -497,7 +497,7 @@ void resolve(int af, void* addr, char* result, int buflen) {
+ hostname = xmalloc(INET6_ADDRSTRLEN);
+ inet_ntop(af, &raddr->addr, hostname, INET6_ADDRSTRLEN);
+
+- hash_insert(ns_hash, raddr, hostname);
++ hash_insert(ns_hash, &raddr->as_addr6, hostname);
+
+ if(((head + 1) % RESOLVE_QUEUE_LENGTH) == tail) {
+ /* queue full */
+--
+libgit2 0.26.0
+
diff --git a/net-analyzer/iftop/files/iftop-1.0_pre4-pthread.patch b/net-analyzer/iftop/files/iftop-1.0_pre4-pthread.patch
deleted file mode 100644
index ce04c46a65ef..000000000000
--- a/net-analyzer/iftop/files/iftop-1.0_pre4-pthread.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -383,39 +383,10 @@
- dnl libraries, etc. We use a test program to figure this stuff out.
- dnl
-
--AC_MSG_CHECKING([POSIX threads compilation])
--thrfail=1
--oldCFLAGS=$CFLAGS
--oldLIBS=$LIBS
--for flag in "" -mt -pthread -thread ; do
-- CFLAGS="$oldCFLAGS $flag"
-- for lib in "" -lpthread "-lpthread -lposix4" ; do
-- LIBS="$oldLIBS $lib"
-- AC_LINK_IFELSE([AC_LANG_SOURCE([`cat config/pthread.c`])], [
-- foundthrlib=$lib
-- foundthrflag=$flag
-- thrfail=0
-- break
-- ])
-- done
-- if test $thrfail = 0 ; then
-- break
-- fi
--done
--
--if test $thrfail = 1 ; then
-- AC_MSG_RESULT([no idea])
-- AC_MSG_ERROR([can't figure out how to compile with POSIX threads
-- If your system actually supports POSIX threads, this means we've messed up.])
--fi
--
--AC_MSG_RESULT([CFLAGS=$foundthrflag and LIBS=$foundthrlib])
--AC_MSG_CHECKING([POSIX threads usability])
--AC_RUN_IFELSE([AC_LANG_SOURCE([`cat config/pthread.c`])],
-- [AC_MSG_RESULT([yes])],
-- [AC_MSG_ERROR(
-- [it fails. We probably guessed the wrong CFLAGS.])],
-- [AC_MSG_RESULT([can't test because we are cross-compiling])])
-+AX_PTHREAD(
-+ [LIBS="$PTHREAD_LIBS $LIBS"
-+ CFLAGS="$CFLAGS $PTHREAD_CFLAGS"],
-+ AC_MSG_ERROR([Could not find out how to enable POSIX threads]))
-
- dnl
- dnl Are we on a system (like Solaris) that requires promiscuous mode in order to
diff --git a/net-analyzer/iftop/files/iftop-1.0_pre4-tinfo.patch b/net-analyzer/iftop/files/iftop-1.0_pre4-tinfo.patch
deleted file mode 100644
index bb14b3c6ca47..000000000000
--- a/net-analyzer/iftop/files/iftop-1.0_pre4-tinfo.patch
+++ /dev/null
@@ -1,55 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -25,7 +25,7 @@ iftop_SOURCES = addr_hash.c edline.c hash.c iftop.c ns_hash.c \
- # addrs_ioctl.c addrs_dlpi.c dlcommon.c \
- # stringmap.c cfgfile.c
-
--
-+iftop_LDADD = $(ncurses_LIBS)
-
- noinst_HEADERS = addr_hash.h ether.h ethertype.h extract.h hash.h iftop.h \
- integers.h ip.h llc.h ns_hash.h options.h resolver.h \
---- a/configure.ac
-+++ b/configure.ac
-@@ -348,29 +348,27 @@
- dnl AC_SEARCH_LIBS....
- dnl
-
--AC_MSG_CHECKING([for a curses library containing mvchgat])
--oldLIBS=$LIBS
--for curseslib in ncursesw curses ncurses ; do
-- LIBS="$oldLIBS -l$curseslib"
-- AC_TRY_LINK([
-+PKG_CHECK_MODULES([ncurses], [ncursesw], [foundcurseslib="$ncurses_LIBS"], [
-+ PKG_CHECK_MODULES([ncurses], [ncurses], [foundcurseslib="$ncurses_LIBS"], [
-+ AC_MSG_CHECKING([for a curses library containing mvchgat])
-+ oldLIBS=$LIBS
-+ for curseslib in ncursesw curses ncurses ; do
-+ LIBS="$oldLIBS -l$curseslib"
-+ AC_TRY_LINK([
- #include <$curseslib.h>
- ], [
- mvchgat(0, 0, 1, A_REVERSE, 0, NULL)
- ], [
-- foundcurseslib=$curseslib
-+ foundcurseslib=-l$curseslib
- break
- ])
--done
--
--if test x$foundcurseslib = x ; then
-- AC_MSG_RESULT([none found])
-+ done
-+ ],
- AC_MSG_ERROR([Curses! Foiled again!
- (Can't find a curses library supporting mvchgat.)
- Consider installing ncurses.])
--else
-- AC_MSG_RESULT([-l$foundcurseslib])
--fi
--
-+ )
-+])
-
- dnl
- dnl POSIX threads. Different systems like different combinations of flags,