summaryrefslogtreecommitdiff
path: root/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'net-analyzer/ifstatus/ifstatus-2.0.0.ebuild')
-rw-r--r--net-analyzer/ifstatus/ifstatus-2.0.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild b/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
new file mode 100644
index 000000000000..7b2612d29fee
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time"
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=sys-libs/ncurses-4.2:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.0-tinfo.patch
+)
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ tc-export CXX PKG_CONFIG
+ emake GCC=$(tc-getCXX) ${PN}
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}