summaryrefslogtreecommitdiff
path: root/net-analyzer/icinga-web
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-21 20:47:17 +0000
commit4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (patch)
treef7640b8b96a04499f1ce44a2cad122d45a8373bd /net-analyzer/icinga-web
parent48bdeb0db9c7ffed22c6eb859ee40b55ba598b86 (diff)
gentoo resync : 21.12.2017
Diffstat (limited to 'net-analyzer/icinga-web')
-rw-r--r--net-analyzer/icinga-web/Manifest2
-rw-r--r--net-analyzer/icinga-web/icinga-web-1.14.1.ebuild205
2 files changed, 207 insertions, 0 deletions
diff --git a/net-analyzer/icinga-web/Manifest b/net-analyzer/icinga-web/Manifest
index 1c2656b91c71..5fbbd92aaf10 100644
--- a/net-analyzer/icinga-web/Manifest
+++ b/net-analyzer/icinga-web/Manifest
@@ -1,3 +1,5 @@
DIST icinga-web-1.14.0.tar.gz 14523746 BLAKE2B cff22c031ecc8af73690ea69c692b530aebd3f35c7a148999aedd9b142a6c304a88ee62af28ac0f80c09174bde6c1af15131596ad2ae8a7c3238a247261adc60 SHA512 9e429ffaf84efb08e0ad009af2dd90179366d4de5720bc09574228d3a6dec967eddc04402f5fac220e7af14761afec4b9021f70255102829e21880591d702d3b
+DIST icinga-web-1.14.1.tar.gz 14524043 BLAKE2B 0a3bdf9afc77b508dd3967e38050f6babfe01240f8cf8196158abe42818079b09a962513541298d0b0ac2b1497640d292cf1ef4feac24e302c0622f6ef0fafd8 SHA512 1ddb1fe128c2ceff20e232d61d84abebbe9578f2ef9bf0c408523c399ab6125dedc7d4e82981fff113aba8959a1ac02712032b4a36e5aa951850c084792a47bb
EBUILD icinga-web-1.14.0.ebuild 6360 BLAKE2B 361c749beca799db709a9dce0bc449e668a61cedab1d03b2a974dcc523918aa9a20aa48042a6f3446e236d24645707ca57dd2a44b562b390eefe436fb71733e0 SHA512 2f0e86345412a2af5541fe9dfb949abef6f7fd53018c65b876ef9d1a64b3c7cac015f49f8f4f8716f28fe2a6d4136dff3da448ce8f92e7816d86ce2c80e1fc2b
+EBUILD icinga-web-1.14.1.ebuild 6360 BLAKE2B f8962deafc94072f82cab470c1259b523be0bbdbfddb29fd821d8861117e5c10c481c15de2a5f97f081ba99ad7a3eeb77730a2eda7f8b3d2317a0a54ba55a5d7 SHA512 2f16087f01e522ebcfda874a5cdd7cbcf9778dc0d032009212717cb9a28eae1fb0df3f9f8cd89705af13a66e9bce3f20c004684de6891bef6e457043844f1f07
MISC metadata.xml 565 BLAKE2B 8f3d66d10fc929779bccaed43db56800be1cd81ed044b0244e8db73b89d9587b9554a59915477dccf5fb0bd7d4f96d9b6330a9309c0e79d20bbd458d827bdfbe SHA512 534f181a73fff13650cd97081c748cf0d75424bab7826ac83eda2a09e6cd3737fd447db3ad9a0207b2cdb24cc84f0515ad5282de2024ec6eddae2a85be41a084
diff --git a/net-analyzer/icinga-web/icinga-web-1.14.1.ebuild b/net-analyzer/icinga-web/icinga-web-1.14.1.ebuild
new file mode 100644
index 000000000000..cac1bd8c81a5
--- /dev/null
+++ b/net-analyzer/icinga-web/icinga-web-1.14.1.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit depend.apache eutils user multilib
+
+DESCRIPTION="Icinga Web - new Web Interface"
+HOMEPAGE="http://www.icinga.org/"
+SRC_URI="https://github.com/icinga/${PN}/archive/v${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="apache2 mysql pnp postgres"
+DEPEND="dev-php/phing
+ dev-db/libdbi-drivers[mysql?,postgres?]
+ || ( >=net-analyzer/icinga-1.10.0 >=net-analyzer/icinga2-2.1.1 )
+ dev-lang/php:=[apache2?,cli,json,mysql?,pdo,postgres?,sockets,xslt,xml]
+ pnp? ( net-analyzer/pnp4nagios )"
+RDEPEND="${DEPEND}"
+
+want_apache2
+
+pkg_setup() {
+ if use apache2 ; then
+ depend.apache_pkg_setup
+ fi
+ enewgroup icinga
+ enewgroup nagios
+ enewuser icinga -1 -1 /var/lib/icinga "icinga,nagios"
+}
+
+src_prepare() {
+ #removed checks for some php stuff since we have these things called use flags
+ sed -i 's/ACICINGA_CHECK_PHP_MODULE/\#ACICINGA_CHECK_PHP_MODULE/g' configure.ac
+ sed -i 's/make\ /make\ \-j1\ /g' lib/Makefile.in
+ autoreconf
+}
+
+src_configure() {
+ local myconf
+
+ myconf="--prefix=/usr/share/icinga/icinga-web
+ --bindir=/usr/sbin
+ --sbindir=/usr/$(get_libdir)/icinga/cgi-bin
+ --datarootdir=/usr/share/icinga/htdocs
+ --localstatedir=/var/lib/icinga
+ --sysconfdir=/etc/icinga
+ --libexecdir=/usr/$(get_libdir)/icinga/plugins
+ --with-bin-user=icinga
+ --with-bin-group=nagios
+ --with-api-cmd-file=/var/lib/icinga/rw/icinga.cmd
+ --with-conf-dir=/etc/icinga-web
+ --with-log-dir=/var/log/icinga-web
+ --with-icinga-objects-dir=/etc/icinga/objects
+ --with-icinga-bin=/usr/sbin/icinga
+ --with-icinga-cfg=/etc/icinga/icinga.cfg"
+
+ if use apache2 ; then
+ myconf+=" --with-web-user=apache
+ --with-web-group=apache
+ --with-web-apache-path=${APACHE_MODULES_CONFDIR}"
+ else
+ myconf+=" --with-web-user=root
+ --with-web-group=root"
+ fi
+
+ if use postgres ; then
+ myconf+=" --with-db-type=pgsql
+ --with-db-port=5432
+ --with-api-subtype=pgsql
+ --with-api-port=5432"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ dodoc README
+ rm -f README
+
+ emake -j1 DESTDIR="${D}" install
+
+ emake DESTDIR="${D}" install-javascript
+
+ if use apache2 ; then
+ dodir ${APACHE_MODULES_CONFDIR}
+ emake DESTDIR="${D}" install-apache-config
+ echo '<IfDefine ICINGA_WEB>' > "${D}/${APACHE_MODULES_CONFDIR}/99_icinga-web.conf"
+ cat "${WORKDIR}/${P}/etc/apache2/icinga-web.conf" >> "${D}/${APACHE_MODULES_CONFDIR}/99_icinga-web.conf"
+ rm "${D}/${APACHE_MODULES_CONFDIR}/icinga-web.conf" || die "rm failed"
+ echo '</IfDefine>' >> "${D}/${APACHE_MODULES_CONFDIR}/99_icinga-web.conf"
+ fi
+
+ insinto /usr/share/icinga/icinga-web/contrib
+ doins -r etc/schema/*
+
+ if use apache2 ; then
+ sed -i 's/%%USER%%/apache/g' etc/scheduler/icingaCron
+ else
+ sed -i 's/%%USER%%/root/g' etc/scheduler/icingaCron
+ fi
+ sed -i 's/%%PATH%%/\/usr\/share\/icinga\/icinga-web/g' etc/scheduler/icingaCron
+
+ dodir /usr/share/icinga/icinga-web/cron/
+ cat - >> "${D}"/usr/share/icinga/icinga-web/cron/crontab <<EOF
+# Force the shell to bash
+SHELL=/bin/bash
+#mail to root
+MAILTO=root
+
+#runs every minute
+* * * * * /usr/bin/php /usr/share/icinga/icinga-web/lib/icingaScheduler/icingaCron.php --useAgavi --exec >> /var/log/icinga-web/cron_error.log
+EOF
+
+ cat - >> "${D}"/usr/share/icinga/icinga-web/cron/fcrontab <<EOF
+# Mail reports to root
+!mailto(root)
+
+#runs every minute
+@ 1 /usr/bin/php /usr/share/icinga/icinga-web/lib/icingaScheduler/icingaCron.php --useAgavi --exec >> /var/log/icinga-web/cron_error.log
+EOF
+
+ if use apache2 ; then
+ diropts -o apache -g apache
+ else
+ diropts -o root -g root
+ fi
+ dodir /var/log/icinga-web
+
+ if use apache2 ; then
+ fowners apache:apache /usr/share/icinga/icinga-web/lib/icingaScheduler/res/storage.dat
+ else
+ fowners root:root /usr/share/icinga/icinga-web/lib/icingaScheduler/res/storage.dat
+ fi
+
+ if use pnp ; then
+ insinto /usr/share/icinga/icinga-web/app/modules/Cronks/data/xml/extensions/
+ doins contrib/PNP_Integration/templateExtensions/pnp-host-extension.xml
+ doins contrib/PNP_Integration/templateExtensions/pnp-service-extension.xml
+ fi
+}
+
+pkg_config() {
+ einfo "press enter to install the icinga-web crontab"
+ einfo "installation from /usr/share/icinga/icinga-web/cron/icingaCron"
+ einfo
+ read
+
+ if has_version sys-process/fcron; then
+ fcrontab - -u root < /usr/share/icinga/icinga-web/cron/fcrontab
+ else
+ crontab - -u root < /usr/share/icinga/icinga-web/cron/crontab
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If this is a new install, you must create a new database for it, e.g. icinga_web."
+ einfo "You can find the database scripts in /usr/share/icinga/icinga-web/contrib/."
+ einfo
+ einfo "Additionally, you need to setup a database user."
+ einfo "The user must have default data privileges like SELECT, UPDATE, INSERT, DELETE."
+ einfo
+ einfo "Example for a MySQL database:"
+ einfo " echo \"CREATE DATABASE icinga_web;\" | mysql"
+ einfo " echo \"GRANT SELECT,UPDATE,INSERT,DELETE ON icinga_web.* TO 'icinga_web'@'localhost' IDENTIFIED BY 'xxxxxx';\" | mysql"
+ einfo " echo \"FLUSH PRIVILEGES;\" | mysql"
+ einfo
+ einfo " cat /usr/share/icinga/icinga-web/contrib/mysql.sql | mysql icinga_web"
+ einfo
+
+ ewarn
+ ewarn "If you're upgrading from a previous release, you must upgrade your database schema."
+ ewarn "You can find upgrade scripts in /usr/share/icinga/icinga-web/contrib/updates/."
+ ewarn
+ ewarn "IMPORTANT: If you are upgrading from an older version and there are other versions in between,"
+ ewarn " be advised that you need to apply those upgrade files with incremental steps!"
+ ewarn
+ ewarn "Example to upgrade a MySQL database:"
+ ewarn " cat /usr/share/icinga/icinga-web/contrib/updates/mysql_<oldversion>_to_<newversion>.sql | mysql icinga_web"
+ ewarn
+ ewarn "Don't forget to clear the config cache."
+ ewarn " /usr/share/icinga/icinga-web/bin/clearcache.sh"
+ ewarn
+
+ einfo
+ einfo "Please note that the magic_quotes_gpc setting must be disabled (in both apache and cli php.ini)."
+ einfo
+
+ if use apache2 ; then
+ einfo
+ einfo "apache config was installed into"
+ einfo "/etc/apache2/modules.d/99_icinga-web.conf"
+ einfo
+ einfo "The apache config value for \'ServerTokens\' must be set to at"
+ einfo "least \'Min\'."
+ einfo
+ else
+ einfo
+ einfo "If you are not using apache you may need to change some"
+ einfo "permissions, so that your web server can access files and logs"
+ einfo
+ fi
+}