summaryrefslogtreecommitdiff
path: root/net-analyzer/hydra/hydra-9999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /net-analyzer/hydra/hydra-9999999.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'net-analyzer/hydra/hydra-9999999.ebuild')
-rw-r--r--net-analyzer/hydra/hydra-9999999.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-analyzer/hydra/hydra-9999999.ebuild b/net-analyzer/hydra/hydra-9999999.ebuild
index 3ff5496cc9b3..fd067f1b4ca5 100644
--- a/net-analyzer/hydra/hydra-9999999.ebuild
+++ b/net-analyzer/hydra/hydra-9999999.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit flag-o-matic git-r3 toolchain-funcs
+
+inherit git-r3 toolchain-funcs
DESCRIPTION="Parallelized network login hacker"
HOMEPAGE="https://github.com/vanhauser-thc/thc-hydra"
@@ -10,9 +11,8 @@ EGIT_REPO_URI="https://github.com/vanhauser-thc/thc-hydra"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE="
- debug firebird gcrypt gtk idn libressl memcached mongodb mysql ncp ncurses
+ debug firebird gcrypt gtk idn libressl memcached mongodb mysql ncurses
oracle pcre postgres rdp libssh subversion zlib
"
@@ -31,7 +31,6 @@ RDEPEND="
memcached? ( dev-libs/libmemcached[sasl] )
mongodb? ( dev-libs/mongo-c-driver )
mysql? ( dev-db/mysql-connector-c:0= )
- ncp? ( net-fs/ncpfs )
ncurses? ( sys-libs/ncurses:= )
oracle? ( dev-db/oracle-instantclient-basic )
pcre? ( dev-libs/libpcre )
@@ -41,10 +40,12 @@ RDEPEND="
subversion? ( dev-vcs/subversion )
zlib? ( sys-libs/zlib )
"
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.2-respect-cflags-more.patch
+)
src_prepare() {
default
@@ -64,7 +65,6 @@ src_prepare() {
src_configure() {
# Note: the top level configure script is not autoconf-based
tc-export CC PKG_CONFIG
- append-cflags -fcommon
export OPTS="${CFLAGS}"
@@ -87,12 +87,11 @@ src_configure() {
hydra_sed memcached '-lmemcached' '$( "${PKG_CONFIG}" --libs libmemcached )' '-DLIBMCACHED'
hydra_sed mongodb '-lmongoc-1.0' '$( "${PKG_CONFIG}" --libs libmongoc-1.0 )' '-DLIBMONGODB\|-DLIBBSON'
hydra_sed mysql '-lmysqlclient' '$( ${CTARGET:-${CHOST}}-mysql_config --libs )' '-DLIBMYSQLCLIENT'
- hydra_sed ncp '-lncp' '' '-DLIBNCP'
hydra_sed ncurses '-lcurses' '$( "${PKG_CONFIG}" --libs ncurses )' '-DLIBNCURSES'
hydra_sed pcre '-lpcre' '$( "${PKG_CONFIG}" --libs libpcre )' '-DHAVE_PCRE'
hydra_sed postgres '-lpq' '$( "${PKG_CONFIG}" --libs libpq )' '-DLIBPOSTGRES'
hydra_sed oracle '-locci -lclntsh' '' '-DLIBORACLE'
- hydra_sed rdp '-lfreerdp2' '$( "${PKG_CONFIG}" --libs freerdp2 )' '-DLIBFREERDP2'
+ hydra_sed rdp '-lfreerdp2' '$( "${PKG_CONFIG}" --libs freerdp2 )' '-DLIBFREERDP'
# TODO: https://bugs.gentoo.org/686148
#hydra_sed subversion '-lsvn_client-1 -lapr-1 -laprutil-1 -lsvn_subr-1' '$( "${PKG_CONFIG}" --libs libsvn_client )' '-DLIBSVN'
hydra_sed subversion '-lsvn_client-1 -lapr-1 -laprutil-1 -lsvn_subr-1' '' '-DLIBSVN'