summaryrefslogtreecommitdiff
path: root/net-analyzer/hunt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/hunt/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/hunt/files')
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-exit.patch10
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-flags.patch21
-rw-r--r--net-analyzer/hunt/files/hunt-1.5-log2.patch22
3 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/hunt/files/hunt-1.5-exit.patch b/net-analyzer/hunt/files/hunt-1.5-exit.patch
new file mode 100644
index 000000000000..226093e1795a
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-exit.patch
@@ -0,0 +1,10 @@
+--- a/timer.c
++++ b/timer.c
+@@ -8,6 +8,7 @@
+ */
+ #include <stdio.h>
+ #include <unistd.h>
++#include <stdlib.h> /* exit() */
+ #include "hunt.h"
+
+ struct list timejob_list = LIST_INIT(struct timejob, j_next);
diff --git a/net-analyzer/hunt/files/hunt-1.5-flags.patch b/net-analyzer/hunt/files/hunt-1.5-flags.patch
new file mode 100644
index 000000000000..2ffcd823847e
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-flags.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,7 @@
+-CFLAGS=-Wall -O2 -g -D_REENTRANT
++CFLAGS += -I. -Wall -D_REENTRANT
+ #CFLAGS+=-DSYNC_FAST
+ #CFLAGS+=-D_WITH_LINUX_KERNEL_HDR
+
+-LDFLAGS=
+ #LDFLAGS=-static
+
+ OBJ=hunt.o main.o c/list.o c/hash.o c/array.o util.o net.o \
+@@ -11,7 +10,7 @@
+ addpolicy.o options.o resolv.o timer.o pktrelay.o
+
+ hunt: $(OBJ)
+- $(CC) ${LDFLAGS} -o $@ $^ -lpthread
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lpthread
+
+ hunt_static: $(OBJ)
+ $(CC) ${LDFLAGS} -static -o $@ $^ -lpthread
diff --git a/net-analyzer/hunt/files/hunt-1.5-log2.patch b/net-analyzer/hunt/files/hunt-1.5-log2.patch
new file mode 100644
index 000000000000..fc36eaea1f3b
--- /dev/null
+++ b/net-analyzer/hunt/files/hunt-1.5-log2.patch
@@ -0,0 +1,22 @@
+--- a/hunt.h
++++ b/hunt.h
+@@ -401,7 +401,7 @@
+ void set_tty_color_bg(enum TTY_COLOR fg, enum TTY_COLOR bg);
+
+ int is_power2(unsigned int i);
+-int log2(unsigned int i);
++int _hunt_log2(unsigned int i);
+ int count_mask(unsigned int mask);
+
+
+--- a/util.c
++++ b/util.c
+@@ -70,7 +70,7 @@
+ return i ? 0 : 1;
+ }
+
+-int log2(unsigned int i)
++int _hunt_log2(unsigned int i)
+ {
+ int l = 0;
+