summaryrefslogtreecommitdiff
path: root/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /net-analyzer/hexinject/hexinject-1.6-r1.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'net-analyzer/hexinject/hexinject-1.6-r1.ebuild')
-rw-r--r--net-analyzer/hexinject/hexinject-1.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/hexinject-1.6-r1.ebuild b/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
new file mode 100644
index 000000000000..e36c1803461e
--- /dev/null
+++ b/net-analyzer/hexinject/hexinject-1.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Network packet sniffer and injector"
+HOMEPAGE="http://hexinject.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+tools experimental"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}
+ experimental? ( dev-lang/tcl )"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6-fix-build-system.patch )
+
+src_configure() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ dobin hexinject
+ use tools && dobin hex2raw prettypacket
+ use experimental && dobin packets.tcl
+ einstalldocs
+}