summaryrefslogtreecommitdiff
path: root/net-analyzer/hexinject/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /net-analyzer/hexinject/files
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'net-analyzer/hexinject/files')
-rw-r--r--net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
new file mode 100644
index 000000000000..fbe91199bbfa
--- /dev/null
+++ b/net-analyzer/hexinject/files/hexinject-1.6-fix-build-system.patch
@@ -0,0 +1,18 @@
+Author: holgersson <holgersson@posteo.de>
+Date: Fri Oct 20 18:30:00 2017 +0200
+
+Don’t call gcc directly, and respect CFLAGS. As this project
+is plain C I don’t care fore CXXFLAGS here.
+
+--- a/Makefile 2017-10-20 18:15:11.743805540 +0200
++++ b/Makefile 2017-10-20 18:24:55.120009439 +0200
+@@ -1,6 +1,6 @@
+-CC = gcc
+-CFLAGS = -Wall
+-LDFLAGS = -lpcap
++CC ?= gcc
++CFLAGS += -Wall
++LDFLAGS = -lpcap
+
+ all:
+ $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c