summaryrefslogtreecommitdiff
path: root/net-analyzer/gvm/gvm-22.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
commit0eb9883b5a8a53c253c98d1c77438c39c27c8c97 (patch)
tree47a89f252688f21fcacd066ac01ed1992a453d42 /net-analyzer/gvm/gvm-22.4.ebuild
parentc6872c361190d4f1a559d23458f6cdffb154b0b0 (diff)
gentoo auto-resync : 03:07:2023 - 10:05:34
Diffstat (limited to 'net-analyzer/gvm/gvm-22.4.ebuild')
-rw-r--r--net-analyzer/gvm/gvm-22.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/gvm/gvm-22.4.ebuild b/net-analyzer/gvm/gvm-22.4.ebuild
new file mode 100644
index 000000000000..4639c27b5590
--- /dev/null
+++ b/net-analyzer/gvm/gvm-22.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature systemd
+
+DESCRIPTION="Greenbone Vulnerability Management, previously named OpenVAS"
+HOMEPAGE="https://www.greenbone.net"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli doc +gsa ldap ospd snmp radius"
+
+RDEPEND="
+ >=net-analyzer/gvm-libs-${PV}[doc?,ldap?,radius?]
+ >=net-analyzer/gvmd-${PV}[doc?]
+ >=net-analyzer/openvas-scanner-${PV}[doc?,snmp?]
+ >=net-analyzer/greenbone-feed-sync-23.6.0
+ cli? ( >=net-analyzer/gvm-tools-21.10.0 )
+ gsa? ( >=net-analyzer/gsad-${PV}[doc?] )
+ ospd? ( >=net-analyzer/ospd-openvas-${PV}[doc?] )
+"
+
+src_unpack() {
+ mkdir "${WORKDIR}/${P}"
+}
+
+src_install() {
+ systemd_dounit "${FILESDIR}/${PN}.target"
+ newinitd "${FILESDIR}/${PN}.init" "${PN}"
+}
+
+pkg_postinst() {
+ optfeature "web server scanning and testing tool" net-analyzer/nikto
+ optfeature "IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "port scanner" net-analyzer/nmap
+ optfeature "create results from local security checks" net-analyzer/notus-scanner
+}