summaryrefslogtreecommitdiff
path: root/net-analyzer/gvm/gvm-21.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /net-analyzer/gvm/gvm-21.4.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'net-analyzer/gvm/gvm-21.4.ebuild')
-rw-r--r--net-analyzer/gvm/gvm-21.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-analyzer/gvm/gvm-21.4.ebuild b/net-analyzer/gvm/gvm-21.4.ebuild
new file mode 100644
index 000000000000..6097666ebdc9
--- /dev/null
+++ b/net-analyzer/gvm/gvm-21.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Greenbone Vulnerability Management, previously named OpenVAS"
+HOMEPAGE="https://www.greenbone.net"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli doc +gsa ldap ospd radius"
+
+RDEPEND="
+ >=net-analyzer/gvm-libs-${PV}[doc?,ldap?,radius?]
+ >=net-analyzer/gvmd-${PV}[doc?]
+ >=net-analyzer/openvas-scanner-${PV}[doc?]
+ cli? ( >=net-analyzer/gvm-tools-21.10.0 )
+ gsa? ( >=net-analyzer/gsad-${PV}[doc?] )
+ ospd? ( >=net-analyzer/ospd-openvas-${PV}[doc?] )
+"
+
+pkg_postinst() {
+ optfeature "web server scanning and testing tool" net-analyzer/nikto
+ optfeature "port scanner" net-analyzer/nmap
+ optfeature "IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "OVALdi — an OVAL Interpreter" app-forensics/ovaldi
+}