summaryrefslogtreecommitdiff
path: root/net-analyzer/gvm/gvm-11.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /net-analyzer/gvm/gvm-11.0.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'net-analyzer/gvm/gvm-11.0.0.ebuild')
-rw-r--r--net-analyzer/gvm/gvm-11.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/gvm/gvm-11.0.0.ebuild b/net-analyzer/gvm/gvm-11.0.0.ebuild
new file mode 100644
index 000000000000..46d9ed063ff2
--- /dev/null
+++ b/net-analyzer/gvm/gvm-11.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+DESCRIPTION="Greenbone Vulnerability Management,previously named OpenVAS"
+HOMEPAGE="https://www.greenbone.net/en/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli +cron +extras +gsa ldap ospd radius"
+
+RDEPEND="
+ >=net-analyzer/gvm-libs-11.0.0[extras?,ldap?,radius?]
+ >=net-analyzer/gvmd-9.0.0[extras?]
+ >=net-analyzer/openvas-scanner-7.0.0[cron?,extras?]
+ cli? ( >=net-analyzer/gvm-tools-2.0.0 )
+ gsa? ( >=net-analyzer/greenbone-security-assistant-9.0.0[extras?] )
+ ospd? ( >=net-analyzer/ospd-2.0.0[extras?] )"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Web server scanning and testing tool" net-analyzer/nikto
+ optfeature "Portscanner" net-analyzer/nmap
+ optfeature "IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "Application protocol detection tool" net-analyzer/amap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "Web application attack and audit framework" net-analyzer/w3af
+}