summaryrefslogtreecommitdiff
path: root/net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-03 10:05:34 +0100
commit0eb9883b5a8a53c253c98d1c77438c39c27c8c97 (patch)
tree47a89f252688f21fcacd066ac01ed1992a453d42 /net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild
parentc6872c361190d4f1a559d23458f6cdffb154b0b0 (diff)
gentoo auto-resync : 03:07:2023 - 10:05:34
Diffstat (limited to 'net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild')
-rw-r--r--net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild b/net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild
new file mode 100644
index 000000000000..accfcb9a95f1
--- /dev/null
+++ b/net-analyzer/gvm-tools/gvm-tools-23.4.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="Remote control for Greenbone Vulnerability Manager, previously named openvas-cli"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/gvm-tools/"
+SRC_URI="https://github.com/greenbone/gvm-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=net-analyzer/python-gvm-23.4.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest