summaryrefslogtreecommitdiff
path: root/net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild')
-rw-r--r--net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild b/net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild
new file mode 100644
index 000000000000..b5ee35fcc16b
--- /dev/null
+++ b/net-analyzer/gvm-tools/gvm-tools-21.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Remote control for Greenbone Vulnerability Manager, previously named openvas-cli"
+HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/gvm-tools/"
+SRC_URI="https://github.com/greenbone/gvm-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/python-gvm-20.0.0[${PYTHON_USEDEP}]
+ !net-analyzer/openvas-cli
+ !net-analyzer/openvas-tools"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Fixing tests
+ # Use correct socket path
+ sed -i "s/\/usr\/local\/var\/run\/gvmd.sock/\/var\/run\/gvmd.sock/g" tests/test_parser.py || die
+ # ignore help formating
+ sed -i "s/class HelpFormatting/@unittest.skip('ignoring help formatting')\nclass HelpFormatting/g" tests/test_parser.py || die
+}