summaryrefslogtreecommitdiff
path: root/net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-16 12:04:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-16 12:04:26 +0100
commitb92911550490e2da121ec4b02d3cf60a2d31a17d (patch)
treedc29e698da3b00d42ead3796b35416159e83d57a /net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild
parent7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (diff)
gentoo auto-resync : 16:04:2024 - 12:04:26
Diffstat (limited to 'net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild')
-rw-r--r--net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild b/net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild
deleted file mode 100644
index 7ae049456675..000000000000
--- a/net-analyzer/greenbone-feed-sync/greenbone-feed-sync-24.1.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_USE_PEP517=poetry
-inherit distutils-r1 systemd
-
-DESCRIPTION="New script for syncing the Greenbone Community Feed"
-HOMEPAGE="https://github.com/greenbone/greenbone-feed-sync"
-SRC_URI="https://github.com/greenbone/greenbone-feed-sync/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-3+"
-KEYWORDS="~amd64"
-IUSE="cron"
-
-COMMON_DEPEND="
- acct-user/gvm
- net-misc/rsync
- >=net-analyzer/gvmd-22.5.0
- dev-python/tomli[${PYTHON_USEDEP}]
- >=dev-python/rich-13.2.0[${PYTHON_USEDEP}]
- >=dev-python/shtab-1.6.5[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${COMMON_DEPEND}
- test? ( net-analyzer/pontos[${PYTHON_USEDEP}] )
-"
-RDEPEND="
- ${COMMON_DEPEND}
- cron? ( virtual/cron )
-"
-
-distutils_enable_tests unittest
-
-python_install() {
- distutils-r1_python_install
-
- # greenbone-feed-sync should not be run as root to avoid changing file permissions
- insinto /etc/sudoers.d
- newins - greenbone-feed-sync <<-EOF
- gvm ALL = NOPASSWD: /usr/bin/greenbone-feed-sync
- EOF
-
- fperms 0750 /etc/sudoers.d
- fperms 0440 /etc/sudoers.d/greenbone-feed-sync
-
- if use cron; then
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/${PN}.cron ${PN}
- fi
-
- systemd_dounit "${FILESDIR}/${PN}.timer" "${FILESDIR}/${PN}.service"
-}
-
-pkg_postinst() {
- if [[ -n ${REPLACING_VERSIONS} ]]; then
- return
- fi
-
- if use cron; then
- elog
- elog "Edit ${EROOT}/etc/cron.weekly/greenbone-feed-sync to activate daily feed update!"
- elog
- fi
-
- if systemd_is_booted; then
- elog
- elog "To enable the systemd timer, run the following command:"
- elog " systemctl enable --now greenbone-feed-sync.timer"
- elog
- fi
-}