summaryrefslogtreecommitdiff
path: root/net-analyzer/gr-fosphor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /net-analyzer/gr-fosphor
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'net-analyzer/gr-fosphor')
-rw-r--r--net-analyzer/gr-fosphor/Manifest2
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild25
2 files changed, 15 insertions, 12 deletions
diff --git a/net-analyzer/gr-fosphor/Manifest b/net-analyzer/gr-fosphor/Manifest
index 2cb0b937872c..9a2a330577b9 100644
--- a/net-analyzer/gr-fosphor/Manifest
+++ b/net-analyzer/gr-fosphor/Manifest
@@ -1,2 +1,2 @@
-EBUILD gr-fosphor-9999.ebuild 1190 BLAKE2B bd92fe7810b554ca247c0e84d3b7da1c3d553dec78127334a3a1f5fdae6975d484fcf238c4c397ab2ca30a0fa09d800f6c867ef4575b847e68031cbe3cfd33a4 SHA512 7474b07e0dd4bfd65ed5e594924d60454746668fad49a7f8c2434f0673636599e4d563dacf2db7870a7c60a47fbb5549e3b6f9d4f6923c2314c508a408a5336b
+EBUILD gr-fosphor-9999.ebuild 1301 BLAKE2B f4a9b167ba19ffcbc64a391594c526bfaa52653f5e260ed0057fb8b1a0e6ea34333efb898e573816b9586d8110e487afafdf2efa2d1775ed77f7a01e2b5b9b51 SHA512 18aedf7be6470b6cb41503908c1e3feced546776ca57aecf74294f6d4231f522834d743c2ff0743595a65f3e87e5e6d971410abde00a3931562b42dfe28b5b6f
MISC metadata.xml 308 BLAKE2B 365c82d2c544f94f613bee62f13ab91dcbefd1652fccfec5222a616443714400c686eb5d77c892b44ab0c1badd1877b4bd0dcb9040c98720c13934d567482857 SHA512 cca3e1ffd2ee31e64dbea0f66093f3295b9e1ce2161b9b71dbd1d518a6a0ff83843c684c1c958bffb80b4f4fda9d5a272be8d6ab2ecf6f0fe57202a65a218df9
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index e31c44e5a78a..80888f939b37 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils python-single-r1
@@ -10,9 +10,10 @@ DESCRIPTION="gnuradio fosphor block (GPU spectrum display)"
HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
if [[ ${PV} == 9999* ]]; then
- inherit git-2
+ inherit git-r3
SRC_URI=""
- EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ #EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
KEYWORDS=""
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
@@ -23,14 +24,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+glfw qt4"
+IUSE="+glfw qt4 wxwidgets"
RDEPEND="qt4? (
dev-qt/qtcore:4
dev-qt/qtgui:4
dev-qt/qtopengl:4
)
- >=net-wireless/gnuradio-3.7_rc:0=[qt4?,${PYTHON_USEDEP}]
+ >=net-wireless/gnuradio-3.7_rc:0=[qt4?,wxwidgets?,${PYTHON_USEDEP}]
media-libs/freetype
dev-libs/boost:=
glfw? ( >=media-libs/glfw-3 )
@@ -45,17 +46,19 @@ DEPEND="${RDEPEND}
src_prepare() {
cmake-utils_src_prepare
+ default
}
src_configure() {
# tries to run OpenCL test program, but failing doesn't hurt
addpredict /dev/dri
- local mycmakeargs="
- $(cmake-utils_use_enable glfw GLFW)
- $(cmake-utils_use_enable qt4 QT)
+ local mycmakeargs=(
+ -DENABLE_DEFAULT=OFF
+ -DENABLE_GLFW="$(usex glfw)"
+ -DENABLE_QT="$(usex qt4)"
+ -DENABLE_WX="$(usex wxwidgets)"
-DENABLE_PYTHON=ON
- -DENABLE_WX=OFF
- "
+ )
cmake-utils_src_configure
}