summaryrefslogtreecommitdiff
path: root/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild')
-rw-r--r--net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
index 0eceaac74e02..73f6863f9df9 100644
--- a/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
+++ b/net-analyzer/gr-fosphor/gr-fosphor-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-utils python-single-r1
@@ -11,11 +11,11 @@ HOMEPAGE="https://sdr.osmocom.org/trac/wiki/fosphor"
if [[ ${PV} == 9999* ]]; then
inherit git-r3
- #EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
EGIT_REPO_URI="https://github.com/osmocom/${PN}.git"
- EGIT_BRANCH="gr3.7-qt5"
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ COMMIT="defdd4aca6cd157ccc3b10ea16b5b4f552f34b96"
+ SRC_URI="https://github.com/osmocom/gr-fosphor/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
KEYWORDS="~amd64 ~x86"
fi
@@ -23,7 +23,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="glfw qt5 wxwidgets"
+IUSE="glfw qt5"
RDEPEND="qt5? (
dev-qt/qtcore:5
@@ -31,9 +31,10 @@ RDEPEND="qt5? (
dev-qt/qtopengl:5
dev-qt/qtwidgets:5
)
- >=net-wireless/gnuradio-3.7_rc:0=[qt5,wxwidgets?,${PYTHON_SINGLE_USEDEP}]
- media-libs/freetype
dev-libs/boost:=
+ dev-libs/log4cpp
+ media-libs/freetype
+ =net-wireless/gnuradio-3.8*:0=[qt5,${PYTHON_SINGLE_USEDEP}]
glfw? ( >=media-libs/glfw-3 )
virtual/opencl
virtual/opengl
@@ -57,7 +58,6 @@ src_configure() {
-DENABLE_DEFAULT=OFF
-DENABLE_GLFW="$(usex glfw)"
-DENABLE_QT="$(usex qt5)"
- -DENABLE_WX="$(usex wxwidgets)"
-DENABLE_PYTHON=ON
)
cmake-utils_src_configure