summaryrefslogtreecommitdiff
path: root/net-analyzer/goaccess/goaccess-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /net-analyzer/goaccess/goaccess-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'net-analyzer/goaccess/goaccess-9999.ebuild')
-rw-r--r--net-analyzer/goaccess/goaccess-9999.ebuild29
1 files changed, 11 insertions, 18 deletions
diff --git a/net-analyzer/goaccess/goaccess-9999.ebuild b/net-analyzer/goaccess/goaccess-9999.ebuild
index a5512dc51d48..e029cb0bf444 100644
--- a/net-analyzer/goaccess/goaccess-9999.ebuild
+++ b/net-analyzer/goaccess/goaccess-9999.ebuild
@@ -1,21 +1,25 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-EGIT_REPO_URI="https://github.com/allinurl/${PN}.git"
+inherit autotools
-inherit autotools git-r3
+if [[ ${PV} = *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/allinurl/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://tar.goaccess.io/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux"
+fi
DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
HOMEPAGE="https://goaccess.io"
-SRC_URI=""
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
-IUSE="btree bzip2 debug geoip geoipv2 getline libressl tokyocabinet ssl unicode zlib"
-REQUIRED_USE="btree? ( tokyocabinet ) bzip2? ( btree ) geoipv2? ( geoip ) zlib? ( btree )"
+IUSE="debug geoip geoipv2 getline libressl ssl unicode"
+REQUIRED_USE="geoipv2? ( geoip )"
BDEPEND="virtual/pkgconfig"
RDEPEND="sys-libs/ncurses:0=[unicode?]
@@ -23,14 +27,6 @@ RDEPEND="sys-libs/ncurses:0=[unicode?]
!geoipv2? ( dev-libs/geoip )
geoipv2? ( dev-libs/libmaxminddb:0= )
)
- !tokyocabinet? ( dev-libs/glib:2 )
- tokyocabinet? (
- dev-db/tokyocabinet[bzip2?,zlib?]
- btree? (
- bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )
- )
- )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
@@ -48,11 +44,8 @@ src_prepare() {
src_configure() {
econf \
- "$(use_enable bzip2 bzip)" \
- "$(use_enable zlib)" \
"$(use_enable debug)" \
"$(use_enable geoip geoip "$(usex geoipv2 mmdb legacy)")" \
- "$(use_enable tokyocabinet tcb "$(usex btree btree memhash)")" \
"$(use_enable unicode utf8)" \
"$(use_with getline)" \
"$(use_with ssl openssl)"