summaryrefslogtreecommitdiff
path: root/net-analyzer/flowgrind
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-analyzer/flowgrind
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-analyzer/flowgrind')
-rw-r--r--net-analyzer/flowgrind/Manifest2
-rw-r--r--net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch36
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild49
3 files changed, 87 insertions, 0 deletions
diff --git a/net-analyzer/flowgrind/Manifest b/net-analyzer/flowgrind/Manifest
index a25bbab1953f..51bc55f08070 100644
--- a/net-analyzer/flowgrind/Manifest
+++ b/net-analyzer/flowgrind/Manifest
@@ -1,5 +1,7 @@
+AUX flowgrind-0.8.0-fno-common.patch 744 BLAKE2B 8b7f9f61b875a69e0087c526be21bb0c9cc917c38072b1dda47c77d3e5aa9ba9176742314ead8c03b9cb11e9552e78823f85f6d868f7210b3cd86db5f3df5789 SHA512 98ad53bffd36a7241c4091f5bd86699a699c0edbd4044ffc5861118fcde71ed17278ae3bb56ca95c9444eca04394a592bfce2c1dea35b1574d7fd42568b1797f
DIST flowgrind-0.7.1.tar.bz2 224678 BLAKE2B e5a6759e57950b2484879f6259f9e17ae3fb5a3b49e1e27dfb6c1c89d476dbc693f29b87bf8ab4975fdde30f57dcd9c279ad6508168136b6e2ddd335bba6fc31 SHA512 fe1bc82d8b1b5bbe37989c0d8f24ba87bca73522983b855e249a3fa5e5fc96d9a63190aa94627db2b1bfea63304e453b4bc1c5fd18260fad9bda38313ad912b8
DIST flowgrind-0.8.0.tar.bz2 298730 BLAKE2B e924c9900d24565dc025af47d57173d828eea6a0d0bce462ab1e9cb38a14b1ac14b4148797c164212473852f5c0525161766b115b5a435fbfd673dbde8e14765 SHA512 2af250da696c4d0f613191e7a2e3084b2aa1dc995665a4164324cdb2cc56af7b000b8a2f5d5e7ac8ebbad3ae0ba4fc8eb641afe65c1a842a633c19e95ba3e65a
EBUILD flowgrind-0.7.1.ebuild 597 BLAKE2B 0f4c02b4269c21553c217e736b12d3da21c6271cbb49434c71eefc067dd1e989788e94bc7c17756a76a7395d852bf3b7dacbb9726d0d08fe0bbd6b18f6f9c785 SHA512 726e2858f0869f1022957e48feef2fe2f4b7ae6fc2f366791c73e3ceddca03f715b3882688a288d872e2d7a1f9c99d04ec68bc943f7bcda0718a802e6cb4c5f9
+EBUILD flowgrind-0.8.0-r1.ebuild 854 BLAKE2B a5630fad5729ea7c67756cb9b3e79d495c88774067eb2ef0a27740ac1536514309473267b742dacde853f7d2844b4812588de9e3665131e7dc92a4bb56329512 SHA512 ad9e4b5bae3f2a2dfa2c8264017ba24cb1a8f3223bf4be775d428dda09e887482ef2d64c1d474adcb1ed0a0bcbd98474cb7a608772ef9c635020576cadcd327a
EBUILD flowgrind-0.8.0.ebuild 789 BLAKE2B 07691d97c3ede3cafc3c40a8e43aaf8059f7da5bad4d010c937dcfc1b857f657c1ab4c33303133499a8991d67a1029fa1652949b6eb89c8f48b9c8077cdbc409 SHA512 b4ec07d9ac0b46f139c92d0e18d5ea74c13f2adef5050ddb236d956788e4abc92329d2ffc2f3c700dbb34cf1d2672306a4e5ac8ee2fbe5c51b271e347836b996
MISC metadata.xml 472 BLAKE2B 8d6d1e17c6f022d5075f2334dcdb92d25f93c81bdb73b182263d87b97796b25859413db86052579a543bdc31eb50de25fe904cf4c396e5c12ce7847bc7b26f72 SHA512 03d9245e17f1411d2c1e45edf41bc7c5fdee8388bfb0f7db01f3ebb91330d80a4055cfac84ce10e7be1090a44320ce7ead685a7420bb96edba6e094d183c9b7e
diff --git a/net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch b/net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch
new file mode 100644
index 000000000000..60835b858816
--- /dev/null
+++ b/net-analyzer/flowgrind/files/flowgrind-0.8.0-fno-common.patch
@@ -0,0 +1,36 @@
+--- a/src/daemon.c
++++ b/src/daemon.c
+@@ -86,6 +86,10 @@
+
+ int daemon_pipe[2];
+
++pthread_t daemon_thread;
++char *dump_prefix;
++char *dump_dir;
++
+ pthread_mutex_t mutex;
+ struct request *requests = 0, *requests_last = 0;
+
+--- a/src/daemon.h
++++ b/src/daemon.h
+@@ -252,7 +252,7 @@
+ int num_flows;
+ };
+
+-pthread_t daemon_thread;
++extern pthread_t daemon_thread;
+
+ /* Through this pipe we wakeup the thread from select */
+ extern int daemon_pipe[2];
+@@ -268,9 +268,8 @@
+ * large a reply can get */
+ struct report* get_reports(int *has_more);
+
+-/* FIXME: shouldn't be global? */
+-char *dump_prefix;
+-char *dump_dir;
++extern char *dump_prefix;
++extern char *dump_dir;
+
+ void *daemon_main(void* ptr);
+ void add_report(struct report* report);
diff --git a/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild b/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..2c2e1839abfa
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.8.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc gsl pcap"
+
+RDEPEND="
+ dev-libs/xmlrpc-c[abyss,curl]
+ sys-apps/util-linux
+ gsl? ( sci-libs/gsl )
+ pcap? ( net-libs/libpcap )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-fno-common.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_with doc doxygen) \
+ $(use_with gsl) \
+ $(use_with pcap)
+}
+
+src_compile() {
+ default
+
+ use doc && emake html
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r doc/html
+}