summaryrefslogtreecommitdiff
path: root/net-analyzer/fail2ban/fail2ban-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 22:04:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 22:04:01 +0100
commita55e5c074db9bb024358a8f0bd2c5e992b7cf6f6 (patch)
treeee290879083a50ef99b06b22b9b3e46e38e281b5 /net-analyzer/fail2ban/fail2ban-9999.ebuild
parent8164a4e49d69b936f2d820456e48468dc0e241ad (diff)
gentoo auto-resync : 02:07:2023 - 22:04:01
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-9999.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-9999.ebuild34
1 files changed, 12 insertions, 22 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-9999.ebuild b/net-analyzer/fail2ban/fail2ban-9999.ebuild
index ed94d18e70a8..b657eb644f4a 100644
--- a/net-analyzer/fail2ban/fail2ban-9999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-9999.ebuild
@@ -4,7 +4,8 @@
EAPI=8
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=( python3_{9..11} )
+DISUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
inherit bash-completion-r1 distutils-r1 systemd tmpfiles
@@ -29,10 +30,8 @@ RDEPEND="
selinux? ( sec-policy/selinux-fail2ban )
systemd? (
$(python_gen_cond_dep '
- || (
- dev-python/python-systemd[${PYTHON_USEDEP}]
- sys-apps/systemd[python(-),${PYTHON_USEDEP}]
- )' 'python*' )
+ dev-python/python-systemd[${PYTHON_USEDEP}]
+ ')
)
"
@@ -40,6 +39,7 @@ DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )
PATCHES=(
"${FILESDIR}"/${PN}-0.11.2-adjust-apache-logs-paths.patch
+ "${FILESDIR}"/${PN}-1.0.2-umask-tests.patch
)
python_prepare_all() {
@@ -50,19 +50,15 @@ python_prepare_all() {
sed -i -e 's|/var\(/run/fail2ban\)|\1|g' {} + || die
}
-python_compile() {
- ./fail2ban-2to3 || die
- distutils-r1_python_compile
-}
-
python_test() {
+ # Skip testRepairDb for bug #907348 (didn't always fail..)
bin/fail2ban-testcases \
--no-network \
- --no-gamin \
+ --ignore databasetestcase.DatabaseTest.testRepairDb \
--verbosity=4 || die "Tests failed with ${EPYTHON}"
# Workaround for bug #790251
- rm -r fail2ban.egg-info || die
+ rm -rf fail2ban.egg-info || die
}
python_install_all() {
@@ -100,7 +96,7 @@ pkg_preinst() {
pkg_postinst() {
tmpfiles_process ${PN}-tmpfiles.conf
- if [[ ${previous_less_than_0_7} = 0 ]] ; then
+ if [[ ${previous_less_than_0_7} == 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"
@@ -113,10 +109,9 @@ pkg_postinst() {
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
- if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin ; then
- elog "For most jail.conf configurations, it is recommended you install either"
- elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
- elog "to control how log file modifications are detected"
+ if ! has_version dev-python/pyinotify ; then
+ elog "For most jail.conf configurations, it is recommended you install"
+ elog "dev-python/pyinotify to control how log file modifications are detected"
fi
if ! has_version dev-lang/python[sqlite] ; then
@@ -125,9 +120,4 @@ pkg_postinst() {
elog "persistent database feature, then you should set"
elog "dbfile = :memory: in fail2ban.conf accordingly."
fi
-
- if has_version sys-apps/systemd[-python] ; then
- elog "If you want to track logins through sys-apps/systemd's"
- elog "journal backend, then reinstall sys-apps/systemd with USE=python"
- fi
}