summaryrefslogtreecommitdiff
path: root/net-analyzer/ethloop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /net-analyzer/ethloop
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'net-analyzer/ethloop')
-rw-r--r--net-analyzer/ethloop/Manifest1
-rw-r--r--net-analyzer/ethloop/files/ethloop-10-gcc45.patch32
2 files changed, 0 insertions, 33 deletions
diff --git a/net-analyzer/ethloop/Manifest b/net-analyzer/ethloop/Manifest
index 15e5958685ab..152d7dedf6c5 100644
--- a/net-analyzer/ethloop/Manifest
+++ b/net-analyzer/ethloop/Manifest
@@ -1,4 +1,3 @@
-AUX ethloop-10-gcc45.patch 712 BLAKE2B b7a58c136663860120467fef7e752b957383d8e5e84325bfda20873581673937e669044a67a61b02080570397e5599e207162e430c910e319d4f32db30a9b412 SHA512 c10c7b723698dc6426478b7e9d861a7a88c887a6df3033c8080f51149882925952ff6cf0d0c7ca1d35dcda2c43cb278d8c4475a37d8be3a5a653c974b48bb7b2
AUX ethloop-10-misc.patch 1760 BLAKE2B f3e22dc20e87bae4d9deab283581f12330ab4535394c1fb1fb787dc7d550a63da64ab936c3b89f06aa3dc218357eaa7ce8a41de9006b62a31c7026f2c75cf51f SHA512 0bb1bacf5103e9b3715c0242844e90007ea68715dbf51abc12c14c845277f6520023c59f4e014cb955552d7dc7854ebe46524e6f5dc2faf47cb145a844fe5ba1
DIST ethloop10.tgz 3912 BLAKE2B 4cd0ad93693afb2302627b9fcbefa94eefec3d29c55e583c5126aed9cfb20aa7a2d68834fa138debaf767972e7e898245d7297567b322953e1df03b3817a5609 SHA512 82ac0114d0d539f5c057101e1e1f0e2eac32e0bd482bd62e6305f7c4863d0776dcff7bc85167dbcfb136d0b430c9008241c2c0250713beb2703cb052b9b71e63
EBUILD ethloop-10-r4.ebuild 565 BLAKE2B ed6cfa4ee8fc45e88898ed4805c5eeeb841a22dc6d738a4c6d3b6bdb8d3c86575fbe21975a6a3e77d37aeecc9bab377a2613f7c323c8f214bd18a36ee8355096 SHA512 0ac1d22150a61d075392e20a4fa91b744cad5989f0220e26f08909a6312332238f516bfcf960aa6f53038f5e0a641b9fa8eec165ed6927ecbcbf1d3affd5c90a
diff --git a/net-analyzer/ethloop/files/ethloop-10-gcc45.patch b/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
deleted file mode 100644
index bf905cd44b2c..000000000000
--- a/net-analyzer/ethloop/files/ethloop-10-gcc45.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix recv call (bug #336755), add some more includes.
-
---- a/ethloop.c
-+++ b/ethloop.c
-@@ -1,5 +1,7 @@
- /* vim: cin sw=4 ts=4
- */
-+#include <arpa/inet.h> /* htons() */
-+#include <sys/types.h> /* recv() */
- #include <sys/socket.h>
- #include <sys/ioctl.h>
- #include <sys/poll.h>
-@@ -13,6 +15,7 @@
- #include <stdlib.h>
- #include <sys/time.h>
- #include <signal.h>
-+#include <string.h>
-
- int sock;
-
-@@ -133,9 +136,9 @@
- int recv_raw(int tmo)
- {
- struct pollfd pf = {sock,POLLIN,0};
-- int r; unsigned short proto;
-+ ssize_t r; unsigned short proto;
- if(poll(&pf,1,tmo) <= 0) return 0;
-- r = recv(sock,&buf,1550,0);
-+ r = recv(sock,&buf,sizeof(buf),0);
- if (r <= 0) {
- printf("error recv (%d)\n",r);
- return 0;