summaryrefslogtreecommitdiff
path: root/net-analyzer/egressor/egressor-1.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-analyzer/egressor/egressor-1.0-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-analyzer/egressor/egressor-1.0-r2.ebuild')
-rw-r--r--net-analyzer/egressor/egressor-1.0-r2.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/net-analyzer/egressor/egressor-1.0-r2.ebuild b/net-analyzer/egressor/egressor-1.0-r2.ebuild
index 528e269b5891..6a3ea8056e36 100644
--- a/net-analyzer/egressor/egressor-1.0-r2.ebuild
+++ b/net-analyzer/egressor/egressor-1.0-r2.ebuild
@@ -1,30 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="tool for checking router configuration"
HOMEPAGE="http://packetfactory.openwall.net/projects/egressor/"
SRC_URI="http://packetfactory.openwall.net/projects/egressor/${PN}_release${PV}.tar.gz"
+S="${WORKDIR}"
LICENSE="egressor"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-DEPEND="<net-libs/libnet-1.1
- >=net-libs/libnet-1.0.2a-r3"
-RDEPEND="net-libs/libpcap
+DEPEND="
+ <net-libs/libnet-1.1
+ >=net-libs/libnet-1.0.2a-r3
+"
+RDEPEND="
+ net-libs/libpcap
dev-perl/Net-RawIP
- dev-lang/perl"
-
-S=${WORKDIR}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-libnet-1.0.patch \
- "${FILESDIR}"/${PV}-flags.patch
-}
+ dev-lang/perl
+"
+PATCHES=(
+ "${FILESDIR}"/${PV}-libnet-1.0.patch
+ "${FILESDIR}"/${PV}-flags.patch
+)
src_compile() {
tc-export CC