summaryrefslogtreecommitdiff
path: root/net-analyzer/cutter/cutter-1.04.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/cutter/cutter-1.04.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/cutter/cutter-1.04.ebuild')
-rw-r--r--net-analyzer/cutter/cutter-1.04.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/cutter/cutter-1.04.ebuild b/net-analyzer/cutter/cutter-1.04.ebuild
new file mode 100644
index 000000000000..f11002ca418e
--- /dev/null
+++ b/net-analyzer/cutter/cutter-1.04.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TCP/IP Connection cutting on Linux Firewalls and Routers"
+HOMEPAGE="http://www.digitage.co.uk/digitage/software/linux-security/cutter"
+SRC_URI="http://www.digitage.co.uk/digitage/files/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.03-debian.patch
+ rm -f Makefile # implicit rules are better ;x
+}
+
+src_compile() {
+ emake cutter CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin cutter
+ dodoc README
+ doman debian/cutter.8
+}