summaryrefslogtreecommitdiff
path: root/net-analyzer/cnet/cnet-3.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/cnet/cnet-3.3.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/cnet/cnet-3.3.4.ebuild')
-rw-r--r--net-analyzer/cnet/cnet-3.3.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-analyzer/cnet/cnet-3.3.4.ebuild b/net-analyzer/cnet/cnet-3.3.4.ebuild
new file mode 100644
index 000000000000..d0f7d21a3314
--- /dev/null
+++ b/net-analyzer/cnet/cnet-3.3.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Network simulation tool"
+HOMEPAGE="http://www.csse.uwa.edu.au/cnet3/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-lang/tk-8.5
+ dev-libs/elfutils
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS=(
+ 1st.README
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.3.4-gentoo.patch
+ "${FILESDIR}"/${PN}-3.3.1-tcl.patch
+)
+
+src_prepare() {
+ # Set libdir properly
+ sed -i -e "/CNETPATH/s:local/lib:$(get_libdir):" src/preferences.h || die
+ sed -i -e "/^LIBDIR/s:lib:$(get_libdir):" Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ C99="$(tc-getCC) -std=c99" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_install() {
+ default
+
+ if use examples; then
+ dodoc -r examples
+ fi
+}