summaryrefslogtreecommitdiff
path: root/net-analyzer/cbm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/cbm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/cbm/files')
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch10
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch10
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch55
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-tinfo.patch19
4 files changed, 94 insertions, 0 deletions
diff --git a/net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch b/net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch
new file mode 100644
index 000000000000..ae9b58f6e99b
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- a/src/statistics.hpp
++++ b/src/statistics.hpp
+@@ -3,6 +3,7 @@
+
+ #include <list>
+ #include <string>
++#include <sys/time.h>
+
+ namespace statistics {
+
diff --git a/net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch b/net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch
new file mode 100644
index 000000000000..94b50a6877f7
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- a/src/cbm.cpp
++++ b/src/cbm.cpp
+@@ -18,6 +18,7 @@
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <net/if.h>
++#include <unistd.h>
+
+ // Externs
+ extern int optind, opterr, optopt;
diff --git a/net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch b/net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch
new file mode 100644
index 000000000000..4b09bbb69793
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch
@@ -0,0 +1,55 @@
+From bdc4f02a6d7fb1416f36aef89af4592c691576d8 Mon Sep 17 00:00:00 2001
+From: Jari Aalto <jari.aalto@cante.net>
+Date: Mon, 19 Sep 2011 14:27:04 +0300
+Subject: [PATCH] [fix] Headers and status line don't display by Paul Martin
+ <pm@debian.org>
+Organization: Private
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Jari Aalto <jari.aalto@cante.net>
+---
+ src/cbm.cpp | 9 ++++++++-
+ src/widgets/Window.cpp | 2 +-
+ 2 files changed, 9 insertions(+), 2 deletions(-)
+
+index 74282e2..0197443 100644
+--- a/src/cbm.cpp
++++ b/src/cbm.cpp
+@@ -156,13 +156,20 @@ int main(int argc, char **argv) {
+ interfaceTable.setColumns(4);
+ interfaceTable.setActiveStyle(A_BOLD);
+ interfaceTable.setActiveRow(1);
++ // Position the interface table
++ interfaceTable.setPosition(2, 2);
++ interfaceTable.setSize(screen.getWidth() - 4,
++ 8); // TODO
+
+ // Create the detail table
+ VerticalTable detailTable(screen);
+ detailTable.setColumns(2);
+ detailTable.setRows(2);
+ detailTable.setActiveRow(-1);
+-
++ // Position the detail table
++ detailTable.setPosition(2, 12); // TODO
++ detailTable.setSize(screen.getWidth() - 4, 10); // TODO
++
+ // Populate the detail table
+ detailTable.setText (0, 0, "Interface");
+ detailTable.setStyle(0, 0, COLOR_PAIR(COLOR_HEADING) | A_BOLD);
+index 322cb9b..572eef7 100644
+--- a/src/widgets/Window.cpp
++++ b/src/widgets/Window.cpp
+@@ -14,7 +14,7 @@ Window::~Window() {
+ }
+
+ void Window::setPosition(unsigned x, unsigned y) {
+- mvwin((WINDOW*) win_, y, x);
++ mvderwin((WINDOW*) win_, y, x);
+ }
+
+ void Window::setSize(unsigned width, unsigned height) {
+--
+1.7.5.4
+
diff --git a/net-analyzer/cbm/files/cbm-0.1-tinfo.patch b/net-analyzer/cbm/files/cbm-0.1-tinfo.patch
new file mode 100644
index 000000000000..955d762214c4
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -3,4 +3,4 @@
+ cbm_SOURCES = cbm.cpp \
+ ErrnoError.hpp \
+ statistics.cpp statistics.hpp
+-cbm_LDADD = -lncurses widgets/libwidgets.la
++cbm_LDADD = $(ncurses_LIBS) widgets/libwidgets.la
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,8 @@
+
+ # Checks for libraries.
+
++PKG_CHECK_MODULES(ncurses,ncurses)
++
+ # Checks for header files.
+
+ # Checks for typedefs, structures, and compiler characteristics.