summaryrefslogtreecommitdiff
path: root/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /net-analyzer/calamaris/calamaris-2.99.4.5.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'net-analyzer/calamaris/calamaris-2.99.4.5.ebuild')
-rw-r--r--net-analyzer/calamaris/calamaris-2.99.4.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild b/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild
new file mode 100644
index 000000000000..446233781cb7
--- /dev/null
+++ b/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="parses logfiles of a wide variety of web proxy servers and generates reports"
+HOMEPAGE="https://cord.de/calamaris-english"
+SRC_URI="https://cord.de/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/GDGraph
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:\(use lib\).*$:\1 '/usr/share/';:" \
+ calamaris || die
+}
+
+src_install() {
+ dobin calamaris calamaris-cache-convert
+
+ insinto /usr/share/${PN}
+ doins *.pm
+
+ doman calamaris.1
+
+ dodoc BUGS CHANGES EXAMPLES EXAMPLES.v3 README TODO calamaris.conf
+}