summaryrefslogtreecommitdiff
path: root/net-analyzer/cacti-spine/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /net-analyzer/cacti-spine/files
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'net-analyzer/cacti-spine/files')
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch b/net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch
new file mode 100644
index 000000000000..53a220fbf0de
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch
@@ -0,0 +1,33 @@
+https://github.com/Cacti/spine/pull/245
+
+From: Sam James <sam@gentoo.org>
+Date: Fri, 10 Dec 2021 03:42:21 +0000
+Subject: [PATCH] configure.ac: fix bashisms
+
+configure needs to work with a POSIX-compliant shell so we need
+to avoid bashisms like '=='. This fixes configure with e.g. /bin/sh
+provided by dash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,7 +260,7 @@ fi
+ CFLAGS="-I$MYSQL_INC_DIR $CFLAGS"
+
+ unamestr=$(uname)
+-if test $unamestr == 'OpenBSD'; then
++if test $unamestr = 'OpenBSD'; then
+ AC_CHECK_LIB(mysqlclient, mysql_init,
+ [ LIBS="-lmysqlclient -lm $LIBS"
+ AC_DEFINE(HAVE_MYSQL, 1, MySQL Client API)
+@@ -285,8 +285,8 @@ else
+ if test -f $MYSQL_LIB_DIR/libmysqlclient_r.a -o -f $MYSQL_LIB_DIR/libmysqlclient_r.$ShLib ; then
+ LIBS="-lmysqlclient_r -lm -ldl $LIBS"
+ else
+- if test "$HAVE_MYSQL" == "yes"; then
+- if test $unamestr == 'OpenBSD'; then
++ if test "$HAVE_MYSQL" = "yes"; then
++ if test $unamestr = 'OpenBSD'; then
+ LIBS="-lmysqlclient -lm $LIBS"
+ else
+ LIBS="-lmysqlclient -lm -ldl $LIBS"