summaryrefslogtreecommitdiff
path: root/net-analyzer/cacti-spine/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/cacti-spine/files
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/cacti-spine/files')
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch19
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8h-fix-ac-macro.patch11
4 files changed, 52 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch
new file mode 100644
index 000000000000..d60653678a2c
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -239,7 +239,7 @@
+ fi
+ CFLAGS="-I$MYSQL_INC_DIR $CFLAGS"
+
+-AC_CHECK_LIB(mysqlclient_r,mysql_init, LIBS="-lmysqlclient_r",
++AC_CHECK_LIB(mysqlclient_r,mysql_init, LIBS="$LIBS -lmysqlclient_r",
+ AC_MSG_ERROR([MySQL libraries not found])
+ )
+
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch
new file mode 100644
index 000000000000..0d94674ce5a3
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch
@@ -0,0 +1,11 @@
+--- a/ping.c
++++ b/ping.c
+@@ -813,7 +813,7 @@
+ int rv;
+
+ buf = malloc(len*sizeof(char));
+- memset(buf, 0, sizeof(buf));
++ memset(buf, 0, len*sizeof(char));
+
+ while (1) {
+ rv = gethostbyname_r(hostname, &result_buf, buf, len,
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch
new file mode 100644
index 000000000000..5ee62e2279a0
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -251,14 +251,14 @@
+
+ # Net-SNMP includes v3 support and insists on crypto unless compiled --without-openssl
+ AC_MSG_CHECKING([if Net-SNMP needs crypto support])
+-AC_TRY_COMPILE([#include <net-snmp-config.h>], [exit(NETSNMP_USE_OPENSSL != 1);],
++AC_TRY_COMPILE([#include <net-snmp/net-snmp-config.h>], [exit(NETSNMP_USE_OPENSSL != 1);],
+ [ AC_MSG_RESULT(yes)
+ SNMP_SSL=yes
+ ],
+ AC_MSG_RESULT(no)
+ )
+
+-AC_TRY_COMPILE([ #include <net-snmp-config.h>
++AC_TRY_COMPILE([ #include <net-snmp/net-snmp-config.h>
+ #include <net-snmp/utilities.h>
+ #include <net-snmp/net-snmp-includes.h>
+ #include <net-snmp/config_api.h>
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8h-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8h-fix-ac-macro.patch
new file mode 100644
index 000000000000..3f497ac7bce5
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8h-fix-ac-macro.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8h)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,