summaryrefslogtreecommitdiff
path: root/net-analyzer/bsnmp/bsnmp-1.11a.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/bsnmp/bsnmp-1.11a.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/bsnmp/bsnmp-1.11a.ebuild')
-rw-r--r--net-analyzer/bsnmp/bsnmp-1.11a.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/bsnmp/bsnmp-1.11a.ebuild b/net-analyzer/bsnmp/bsnmp-1.11a.ebuild
new file mode 100644
index 000000000000..53220c31acd2
--- /dev/null
+++ b/net-analyzer/bsnmp/bsnmp-1.11a.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Mini-SNMP Daemon and Library"
+HOMEPAGE="http://people.freebsd.org/~harti/"
+SRC_URI="http://people.freebsd.org/~harti/bsnmp/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86-fbsd"
+IUSE="tcpd"
+
+DEPEND="dev-libs/libbegemot
+ tcpd? ( sys-apps/tcp-wrappers )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.10-gcc34.patch"
+}
+
+src_compile() {
+ if use elibc_glibc; then
+ # bsnmp is bsd-based, without this it will fail
+ append-flags "-D_BSD_SOURCE"
+ fi
+
+ filter-flags -fno-inline
+
+ econf \
+ --with-libbegemot=/usr \
+ $(use_with tcpd tcpwrappers) \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ einstall || die "make install failed"
+}