summaryrefslogtreecommitdiff
path: root/net-analyzer/bing/bing-1.1.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /net-analyzer/bing/bing-1.1.3-r2.ebuild
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'net-analyzer/bing/bing-1.1.3-r2.ebuild')
-rw-r--r--net-analyzer/bing/bing-1.1.3-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/bing/bing-1.1.3-r2.ebuild b/net-analyzer/bing/bing-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..83f643000e81
--- /dev/null
+++ b/net-analyzer/bing/bing-1.1.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A point-to-point bandwidth measurement tool"
+SRC_URI="mirror://debian/pool/main/b/bing/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://fgouget.free.fr/bing/index-en.shtml"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~arm ia64 ppc sparc x86"
+
+src_prepare() {
+ default
+ sed -i -e "s:#COPTIM = -g: COPTIM = ${CFLAGS}:" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin bing
+ doman unix/bing.8
+ dodoc ChangeLog Readme.{1st,txt}
+}