summaryrefslogtreecommitdiff
path: root/net-analyzer/bing/bing-1.1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/bing/bing-1.1.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/bing/bing-1.1.3-r1.ebuild')
-rw-r--r--net-analyzer/bing/bing-1.1.3-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/bing/bing-1.1.3-r1.ebuild b/net-analyzer/bing/bing-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..02b9d58b1f04
--- /dev/null
+++ b/net-analyzer/bing/bing-1.1.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit toolchain-funcs
+
+DESCRIPTION="A point-to-point bandwidth measurement tool"
+SRC_URI="mirror://debian/pool/main/b/bing/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://fgouget.free.fr/bing/index-en.shtml"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="amd64 ~arm ia64 ppc sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=">=sys-apps/sed-4"
+
+src_prepare() {
+ sed -i -e "s:#COPTIM = -g: COPTIM = ${CFLAGS}:" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"|| die "emake failed"
+}
+
+src_install() {
+ dobin bing || die
+ doman unix/bing.8 || die
+ dodoc ChangeLog Readme.{1st,txt} || die
+}