summaryrefslogtreecommitdiff
path: root/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-analyzer/authforce/authforce-0.9.9-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-analyzer/authforce/authforce-0.9.9-r1.ebuild')
-rw-r--r--net-analyzer/authforce/authforce-0.9.9-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/authforce/authforce-0.9.9-r1.ebuild b/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
new file mode 100644
index 000000000000..fea985a8e03a
--- /dev/null
+++ b/net-analyzer/authforce/authforce-0.9.9-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit base
+
+DESCRIPTION="An HTTP authentication brute forcer"
+HOMEPAGE="http://www.divineinvasion.net/authforce/"
+SRC_URI="http://www.divineinvasion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="curl nls"
+
+DEPEND="
+ sys-libs/readline
+ curl? ( net-misc/curl )
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS BUGS NEWS README THANKS TODO )
+PATCHES=(
+ "${FILESDIR}"/${P}-curl.patch
+ "${FILESDIR}"/${P}-locale.patch
+ )
+
+src_configure() {
+ econf \
+ $(use_with curl) \
+ $(use_enable nls) \
+ --with-path=/usr/share/${PN}/data:.
+}