summaryrefslogtreecommitdiff
path: root/net-analyzer/arpon/arpon-3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /net-analyzer/arpon/arpon-3.0.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'net-analyzer/arpon/arpon-3.0.ebuild')
-rw-r--r--net-analyzer/arpon/arpon-3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/arpon/arpon-3.0.ebuild b/net-analyzer/arpon/arpon-3.0.ebuild
new file mode 100644
index 000000000000..6d1866670e89
--- /dev/null
+++ b/net-analyzer/arpon/arpon-3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake
+
+DESCRIPTION="ArpON (Arp handler inspectiON) is a portable Arp handler"
+
+MY_PN="ArpON"
+MY_P="${MY_PN}-${PV}"
+HOMEPAGE="http://arpon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-ng.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/libdnet
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0-CFLAGS.patch
+ "${FILESDIR}"/${PN}-3.0-gentoo.patch
+)
+DOCS=( AUTHOR CHANGELOG README THANKS )
+S="${WORKDIR}"/${MY_P}-ng
+
+src_install() {
+ cmake_src_install
+ newinitd "${FILESDIR}"/${PN}.initd-3 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-3 ${PN}
+
+ rm -r "${ED}"/var/{log,run} || die
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}