summaryrefslogtreecommitdiff
path: root/net-analyzer/arping/arping-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /net-analyzer/arping/arping-9999.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'net-analyzer/arping/arping-9999.ebuild')
-rw-r--r--net-analyzer/arping/arping-9999.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/net-analyzer/arping/arping-9999.ebuild b/net-analyzer/arping/arping-9999.ebuild
index 20b7fc882067..13d8502fc949 100644
--- a/net-analyzer/arping/arping-9999.ebuild
+++ b/net-analyzer/arping/arping-9999.ebuild
@@ -1,31 +1,34 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools fcaps git-r3
-DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+inherit autotools git-r3 fcaps
+
+DESCRIPTION="A utility to see if a specific IP is taken and what MAC owns it"
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
EGIT_REPO_URI="https://github.com/ThomasHabets/arping"
+S="${WORKDIR}/${PN}-${P}"
LICENSE="GPL-2"
SLOT="2"
-KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-CDEPEND="
+RDEPEND="
net-libs/libpcap
net-libs/libnet:1.1
+ !net-misc/iputils[arping(+)]
"
DEPEND="
- ${CDEPEND}
- dev-libs/check
-"
-RDEPEND="
- ${CDEPEND}
- !net-misc/iputils[arping(+)]
+ ${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-python/subunit
+ )
"
-FILECAPS=( cap_net_raw /usr/sbin/arping )
+FILECAPS=( cap_net_raw usr/sbin/arping )
src_prepare() {
default