summaryrefslogtreecommitdiff
path: root/net-analyzer/arping/arping-2.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /net-analyzer/arping/arping-2.22.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'net-analyzer/arping/arping-2.22.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.22.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/arping/arping-2.22.ebuild b/net-analyzer/arping/arping-2.22.ebuild
new file mode 100644
index 000000000000..1df1402f5eaa
--- /dev/null
+++ b/net-analyzer/arping/arping-2.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fcaps
+
+DESCRIPTION="A utility to see if a specific IP is taken and what MAC owns it"
+HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
+SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ net-libs/libpcap
+ net-libs/libnet:1.1
+ !net-misc/iputils[arping(+)]
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-python/subunit
+ )
+"
+
+FILECAPS=( cap_net_raw usr/sbin/arping )
+
+src_prepare() {
+ default
+ eautoreconf
+}