summaryrefslogtreecommitdiff
path: root/net-analyzer/amap/amap-5.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /net-analyzer/amap/amap-5.4-r1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'net-analyzer/amap/amap-5.4-r1.ebuild')
-rw-r--r--net-analyzer/amap/amap-5.4-r1.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/net-analyzer/amap/amap-5.4-r1.ebuild b/net-analyzer/amap/amap-5.4-r1.ebuild
index 9848a4c18f2d..2703bd6e4bd7 100644
--- a/net-analyzer/amap/amap-5.4-r1.ebuild
+++ b/net-analyzer/amap/amap-5.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="A network scanning tool for pentesters"
HOMEPAGE="https://www.thc.org/thc-amap/"
@@ -11,7 +11,7 @@ SRC_URI="https://www.thc.org/releases/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ppc ppc64 x86"
IUSE="libressl ssl"
DEPEND="
@@ -26,23 +26,31 @@ RDEPEND="
!sci-biology/amap
"
+PATCHES=(
+ "${FILESDIR}"/4.8-system-pcre.patch
+)
+
src_prepare() {
rm -r pcre-3.9 || die
+
sed -i -e "s:etc/:share/amap/:g" amap-lib.c || die
+
# Above change requires below change. See sources...
sed -i '/strlen(AMAP_PREFIX/s: 5 : 12 :' amap-lib.c || die
sed -i 's:/usr/local:/usr:' amap.h || die
+
# Files to be updated are at different location, bug 207839.
sed -i '/AMAP_RESOURCE/s:www:freeworld:' amap.h || die
sed -i '/DATADIR/s:/etc:/share/amap:' Makefile.am || die
- epatch "${FILESDIR}"/4.8-system-pcre.patch
+ default
}
src_configure() {
# non-autotools configure script
./configure || die
+
sed -i \
-e '/^XDEFINES=/s:=.*:=:' \
-e '/^XLIBS=/s:=.*:=:' \
@@ -50,12 +58,14 @@ src_configure() {
-e '/^XIPATHS=/s:=.*:=:' \
-e "/^CC=/d" \
Makefile || die
+
if use ssl ; then
sed -i \
-e '/^XDEFINES=/s:=:=-DOPENSSL:' \
-e '/^XLIBS=/s:=:=-lcrypto -lssl:' \
Makefile || die
fi
+
sed -i Makefile \
-e '/-o amap/{s|(OPT) |(OPT) $(LDFLAGS) |g}' \
|| die