summaryrefslogtreecommitdiff
path: root/net-analyzer/2ping/2ping-4.5.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /net-analyzer/2ping/2ping-4.5.1-r1.ebuild
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'net-analyzer/2ping/2ping-4.5.1-r1.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-4.5.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-4.5.1-r1.ebuild b/net-analyzer/2ping/2ping-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..e26ab3b49f42
--- /dev/null
+++ b/net-analyzer/2ping/2ping-4.5.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="https://www.finnie.org/software/2ping/"
+SRC_URI="https://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="server"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ doman doc/2ping.1
+ dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
+
+ newbashcomp 2ping.bash_completion 2ping
+ dosym 2ping $(get_bashcompdir)/2ping6
+
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}