summaryrefslogtreecommitdiff
path: root/media-video/yle-dl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /media-video/yle-dl
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest3
-rw-r--r--media-video/yle-dl/metadata.xml12
-rw-r--r--media-video/yle-dl/yle-dl-20190614.ebuild68
3 files changed, 83 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
new file mode 100644
index 000000000000..315406e431bd
--- /dev/null
+++ b/media-video/yle-dl/Manifest
@@ -0,0 +1,3 @@
+DIST yle-dl-20190614.tar.gz 83579 BLAKE2B 9117ab32d3e037f22cc209d3686e23d14802438f77203f08e102901d825c06e7c332d1f6ca33bce3af3d4042e9c543fec60e261153be8ab738b038cc1cf4069b SHA512 6a4bfdb93229f48580d8acf742e1e253aa3da79f84ecc3886c32757ddc46608795c58cd02cb0aaa2f7d42188456eac50a243b815baa3752ac6a1b12b9632109c
+EBUILD yle-dl-20190614.ebuild 1750 BLAKE2B 992a1ac48b8554679e3266e9ad3c5d2c5f1e6b293e382fc4a63ae17c1f657a391da6a1e867bc4b8227335d895cd5016d05e0a11862abde2096fcd871287fb7b0 SHA512 73aba786351d47c70450f0b1f54c93727eee82eda4a062c0b58fc3d45e071312413afd34fbe5db975fb204c3e8e309b68043b83ae850db868f9bad562fc9d296
+MISC metadata.xml 415 BLAKE2B 3961cdbc02847f65011c6987b811207c31c49ae40c3bea44b481f35ac04e75dabfa8ceae74f6adc816f211129efb8faaa0ba63700d95eec569b3f51cfe64bd42 SHA512 96f1afba4a47f7b5dca75ba1d5300baf9815bdcf3eda12f5b6044aea7cfc09683c76db210a0b4965626aac050016fc39f44c4e5c63597894e0ae6457dc2aeb90
diff --git a/media-video/yle-dl/metadata.xml b/media-video/yle-dl/metadata.xml
new file mode 100644
index 000000000000..025d4dde75df
--- /dev/null
+++ b/media-video/yle-dl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>juippis@gentoo.org</email>
+ <name>Joonas Niilola</name>
+ </maintainer>
+ <use>
+ <flag name='php'>Use a PHP script as download backend</flag>
+ <flag name='youtube-dl'>Use youtube-dl script as a download backend</flag>
+ </use>
+</pkgmetadata>
diff --git a/media-video/yle-dl/yle-dl-20190614.ebuild b/media-video/yle-dl/yle-dl-20190614.ebuild
new file mode 100644
index 000000000000..ecd14071a70f
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20190614.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5..6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="http://aajanki.github.io/yle-dl/"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="libav php test +youtube-dl"
+
+# Requires an active internet connection during tests
+RESTRICT="test"
+
+RDEPEND="
+ !libav? ( media-video/ffmpeg )
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ <dev-python/attrs-18.3.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mini-amf[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-misc/wget
+ php? (
+ dev-lang/php:*[bcmath,cli,curl,simplexml]
+ >=dev-libs/openssl-1.0.2:0=
+ media-video/rtmpdump
+ )
+ youtube-dl? ( net-misc/youtube-dl[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_prepare() {
+ default
+
+ # Gentoo doesn't ship pycryptodomex with pycryptodome
+ sed -i 's/pycryptodomex/pycryptodome/g' setup.py || die
+}
+
+python_test() {
+ # For tests to run succesfully, you need to disable network stricting
+ # feature first.
+ # FEATURES="-network-sandbox test" emerge -a yle-dl
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Sample configuration file has been installed in "
+ einfo " /usr/share/doc/yle-dl-2.37/yledl.conf.sample.bz2"
+}