summaryrefslogtreecommitdiff
path: root/media-video/x264-encoder/x264-encoder-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /media-video/x264-encoder/x264-encoder-9999.ebuild
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'media-video/x264-encoder/x264-encoder-9999.ebuild')
-rw-r--r--media-video/x264-encoder/x264-encoder-9999.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/media-video/x264-encoder/x264-encoder-9999.ebuild b/media-video/x264-encoder/x264-encoder-9999.ebuild
index 4958c30688e0..ae007c71112c 100644
--- a/media-video/x264-encoder/x264-encoder-9999.ebuild
+++ b/media-video/x264-encoder/x264-encoder-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic toolchain-funcs
@@ -12,8 +12,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://git.videolan.org/git/x264.git"
SRC_URI=""
else
- inherit versionator
- MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+ MY_P="x264-snapshot-$(ver_cut 3)-2245"
SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
S="${WORKDIR}/${MY_P}"
@@ -21,13 +20,16 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="10bit avs custom-cflags ffmpeg ffmpegsource +interlaced mp4 +threads"
+IUSE="avs custom-cflags ffmpeg ffmpegsource +interlaced libav mp4 +threads"
REQUIRED_USE="ffmpegsource? ( ffmpeg )"
RDEPEND="
- ~media-libs/x264-${PV}[10bit=,interlaced=,threads=]
- ffmpeg? ( virtual/ffmpeg )
+ ~media-libs/x264-${PV}[interlaced=,threads=]
+ ffmpeg? (
+ !libav? ( media-video/ffmpeg:= )
+ libav? ( media-video/libav:= )
+ )
ffmpegsource? ( media-libs/ffmpegsource )
mp4? ( >=media-video/gpac-0.5.2:= )"
@@ -35,8 +37,8 @@ ASM_DEP=">=dev-lang/nasm-2.13"
DEPEND="${RDEPEND}
amd64? ( ${ASM_DEP} )
x86? ( ${ASM_DEP} )
- x86-fbsd? ( ${ASM_DEP} )
- virtual/pkgconfig"
+ x86-fbsd? ( ${ASM_DEP} )"
+BDEPEND="virtual/pkgconfig"
PATCHES=( "${FILESDIR}/gpac.patch" )
@@ -52,7 +54,6 @@ src_configure() {
--system-libx264 \
--host="${CHOST}" \
--disable-lsmash \
- $(usex 10bit "--bit-depth=10" "") \
$(usex avs "" "--disable-avs") \
$(usex ffmpeg "" "--disable-lavf --disable-swscale") \
$(usex ffmpegsource "" "--disable-ffms") \