summaryrefslogtreecommitdiff
path: root/media-video/vstrip/vstrip-0.8f.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-video/vstrip/vstrip-0.8f.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-video/vstrip/vstrip-0.8f.ebuild')
-rw-r--r--media-video/vstrip/vstrip-0.8f.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/media-video/vstrip/vstrip-0.8f.ebuild b/media-video/vstrip/vstrip-0.8f.ebuild
new file mode 100644
index 000000000000..ac2ff90773a0
--- /dev/null
+++ b/media-video/vstrip/vstrip-0.8f.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A program to split non-css dvd vobs into individual chapters"
+HOMEPAGE="http://www.maven.de/code"
+SRC_URI="http://files.digital-digest.com/downloads/files/encode/vStrip_${PV/./}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ edos2unix *.c *.h
+
+ for file in *.c *.h ; do
+ echo >>$file
+ done
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D__UNIX__" CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin vstrip
+}