summaryrefslogtreecommitdiff
path: root/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-26 00:07:28 +0100
commit994fe442814c4d169bb0f1ee9745604928006b39 (patch)
tree630f10f7414f44018095dd9d3cf9df55852a9d41 /media-video/vstrip/files/vstrip-0.8f-gentoo.patch
parentf8999218b5a6eafa151e7367030cbfdb69e045ed (diff)
gentoo auto-resync : 26:05:2024 - 00:07:27
Diffstat (limited to 'media-video/vstrip/files/vstrip-0.8f-gentoo.patch')
-rw-r--r--media-video/vstrip/files/vstrip-0.8f-gentoo.patch63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch b/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
deleted file mode 100644
index d4be5a2ea783..000000000000
--- a/media-video/vstrip/files/vstrip-0.8f-gentoo.patch
+++ /dev/null
@@ -1,63 +0,0 @@
---- a/Makefile
-+++ b/Makefile 2003-10-12 02:25:31.000000000 +0000
-@@ -4,7 +4,7 @@
-
- ### Sources
-
--SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c
-+SOURCE_FILES=file_io.h file_io.c in_buffer.h in_buffer.c parse_ifo.h parse_ifo.c s_types.h main.c vstrip.h vstrip.c dvd2avi_plugin.c
-
- ### Objects and executables
-
-@@ -27,8 +27,8 @@
-
- ### Details
-
--vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o
-- $(CC) -g file_io.o in_buffer.o main.o parse_ifo.o vstrip.o -o vstrip
-+vstrip : file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o
-+ $(CC) $(LDFLAGS) file_io.o in_buffer.o main.o parse_ifo.o vstrip.o dvd2avi_plugin.o -o vstrip -lm
- file_io.o : s_types.h file_io.h file_io.c
- in_buffer.o : s_types.h file_io.h in_buffer.h in_buffer.c
- main.o : s_types.h file_io.h vstrip.h main.c
---- a/dvd2avi_plugin.c
-+++ b/dvd2avi_plugin.c 2003-10-12 02:29:23.000000000 +0000
-@@ -6,13 +6,17 @@
-
- *************************************************************************/
-
-+#include <string.h>
-+#include <stdlib.h>
- #include <stdio.h>
--#include <io.h>
-+#include <sys/io.h>
- #include <fcntl.h>
- #include "s_types.h"
- #include "vstrip.h"
- #include "dvd2avi_plugin.h"
-
-+#define max(a,b) a < b ? b : a
-+
- bool dvd2avi_process(byte *data, tp_vs_streaminfo const si, void *user_data)
- {
- t_dvd2avi* d2v = (t_dvd2avi *)user_data;
-@@ -206,7 +210,7 @@
- fp = _open(fname, _O_BINARY | _O_RDONLY); // check size
- if (fp != -1)
- {
-- __int64 fposition = _filelengthi64(fp);
-+ __int64_t fposition = lseek64(fp, 0, SEEK_END);
-
- lba = (dword)(fposition / fio_SECTOR_SIZE);
- _close(fp);
---- a/file_io.c
-+++ b/file_io.c 2003-10-12 02:24:46.000000000 +0000
-@@ -32,7 +32,7 @@
- fp = _open(name, _O_BINARY | _O_RDONLY); // check size
- if (fp != -1)
- {
-- __int64 fposition = _filelengthi64(fp);
-+ __int64_t fposition = lseek64(fp, 0, SEEK_END);
-
- f->written_to = fposition > 0;
- if (fposition > 0)