summaryrefslogtreecommitdiff
path: root/media-video/vlc/vlc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /media-video/vlc/vlc-9999.ebuild
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'media-video/vlc/vlc-9999.ebuild')
-rw-r--r--media-video/vlc/vlc-9999.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index a8bd9326940d..464b5d025845 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -36,7 +36,7 @@ IUSE="a52 alsa altivec aom archive bidi bluray cddb chromaprint chromecast dbus
macosx-qtkit matroska microdns modplug mp3 mpeg mtp musepack ncurses neon nfs ogg
omxil opencv optimisememory opus png postproc projectm pulseaudio +qt5 rdp rtsp
run-as-root samba schroedinger sdl-image sftp shout sid skins soxr speex srt ssl svg
- taglib theora tremor truetype twolame udev upnp vaapi v4l vcd vdpau vnc vorbis vpx
+ taglib theora tremor truetype twolame udev upnp vaapi v4l vdpau vnc vorbis vpx
wayland wma-fixed +X x264 x265 xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
"
REQUIRED_USE="
@@ -70,7 +70,10 @@ RDEPEND="
bluray? ( media-libs/libbluray:0= )
cddb? ( media-libs/libcddb:0 )
chromaprint? ( media-libs/chromaprint:0= )
- chromecast? ( >=dev-libs/protobuf-2.5.0:= )
+ chromecast? (
+ >=dev-libs/protobuf-2.5.0:=
+ >=net-libs/libmicrodns-0.0.9:=
+ )
dbus? ( sys-apps/dbus:0 )
dc1394? (
media-libs/libdc1394:2
@@ -130,7 +133,6 @@ RDEPEND="
dev-libs/libebml:0=
media-libs/libmatroska:0=
)
- microdns? ( >=net-libs/libmicrodns-0.0.9:= )
modplug? ( media-libs/libmodplug:0 )
mp3? ( media-libs/libmad:0 )
mpeg? ( media-libs/libmpeg2:0 )
@@ -194,7 +196,6 @@ RDEPEND="
upnp? ( net-libs/libupnp:= )
v4l? ( media-libs/libv4l:0 )
vaapi? ( x11-libs/libva:0=[drm,wayland?,X?] )
- vcd? ( >=dev-libs/libcdio-0.78.2:0 )
vdpau? ( x11-libs/libvdpau:0 )
vnc? ( net-libs/libvncserver:0 )
vorbis? ( media-libs/libvorbis:0 )
@@ -234,13 +235,6 @@ DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
S="${WORKDIR}/${MY_P}"
-pkg_pretend() {
- # https://bugs.gentoo.org/647668
- if use chromecast && ! use microdns; then
- einfo "USE=microdns is required for Chromecast autodetection support"
- fi
-}
-
src_prepare() {
default
@@ -280,6 +274,7 @@ src_configure() {
--disable-update-check
--enable-fast-install
--enable-screen
+ --enable-vcd
--enable-vlc
$(use_enable a52)
$(use_enable alsa)
@@ -292,6 +287,7 @@ src_configure() {
$(use_enable cddb libcddb)
$(use_enable chromaprint)
$(use_enable chromecast)
+ $(use_enable chromecast microdns)
$(use_enable cpu_flags_x86_mmx mmx)
$(use_enable cpu_flags_x86_sse sse)
$(use_enable dbus)
@@ -336,7 +332,6 @@ src_configure() {
$(use_enable macosx-notifications osx-notifications)
$(use_enable macosx-qtkit)
$(use_enable matroska)
- $(use_enable microdns)
$(use_enable modplug mod)
$(use_enable mp3 mad)
$(use_enable mpeg libmpeg2)
@@ -378,7 +373,6 @@ src_configure() {
$(use_enable upnp)
$(use_enable v4l v4l2)
$(use_enable vaapi libva)
- $(use_enable vcd)
$(use_enable vdpau)
$(use_enable vnc)
$(use_enable vorbis)