summaryrefslogtreecommitdiff
path: root/media-video/vlc/vlc-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /media-video/vlc/vlc-9999.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'media-video/vlc/vlc-9999.ebuild')
-rw-r--r--media-video/vlc/vlc-9999.ebuild38
1 files changed, 29 insertions, 9 deletions
diff --git a/media-video/vlc/vlc-9999.ebuild b/media-video/vlc/vlc-9999.ebuild
index 21bc19b30620..c86292213343 100644
--- a/media-video/vlc/vlc-9999.ebuild
+++ b/media-video/vlc/vlc-9999.ebuild
@@ -33,14 +33,14 @@ IUSE="a52 alsa altivec aom archive bidi bluray cddb chromaprint chromecast dbus
debug directx dts +dvbpsi dvd +encode faad fdk +ffmpeg flac fluidsynth fontconfig
+gcrypt gme gnome-keyring gstreamer ieee1394 jack jpeg kate libass libav libcaca
libnotify +libsamplerate libtar libtiger linsys lirc live lua macosx-notifications
- macosx-qtkit matroska modplug mp3 mpeg mtp musepack ncurses neon nfs ogg omxil opencv
- optimisememory opus png postproc projectm pulseaudio +qt5 rdp rtsp run-as-root
- samba schroedinger sdl-image sftp shout sid skins speex ssl svg taglib theora tremor
- truetype twolame udev upnp vaapi v4l vcd vdpau vnc vorbis vpx wayland wma-fixed +X
- x264 x265 xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
+ macosx-qtkit matroska microdns modplug mp3 mpeg mtp musepack ncurses neon nfs ogg
+ omxil opencv optimisememory opus png postproc projectm pulseaudio +qt5 rdp rtsp
+ run-as-root samba schroedinger sdl-image sftp shout sid skins speex ssl svg taglib
+ theora tremor truetype twolame udev upnp vaapi v4l vcd vdpau vnc vorbis vpx wayland
+ wma-fixed +X x264 x265 xml zeroconf zvbi cpu_flags_x86_mmx cpu_flags_x86_sse
"
REQUIRED_USE="
- bidi? ( truetype )
+ chromecast? ( encode )
directx? ( ffmpeg )
fontconfig? ( truetype )
libcaca? ( X )
@@ -61,7 +61,12 @@ RDEPEND="
alsa? ( media-libs/alsa-lib:0 )
aom? ( media-libs/libaom:= )
archive? ( app-arch/libarchive:= )
- bidi? ( dev-libs/fribidi:0 )
+ bidi? (
+ dev-libs/fribidi:0
+ media-libs/freetype:2[harfbuzz]
+ media-libs/harfbuzz
+ virtual/ttf-fonts:0
+ )
bluray? ( media-libs/libbluray:0= )
cddb? ( media-libs/libcddb:0 )
chromaprint? ( media-libs/chromaprint:0= )
@@ -125,6 +130,7 @@ RDEPEND="
dev-libs/libebml:0=
media-libs/libmatroska:0=
)
+ microdns? ( >=net-libs/libmicrodns-0.0.9:= )
modplug? ( media-libs/libmodplug:0 )
mp3? ( media-libs/libmad:0 )
mpeg? ( media-libs/libmpeg2:0 )
@@ -226,6 +232,13 @@ DOCS=( AUTHORS THANKS NEWS README doc/fortunes.txt )
S="${WORKDIR}/${MY_P}"
+pkg_pretend() {
+ # https://bugs.gentoo.org/647668
+ if use chromecast && ! use microdns; then
+ einfo "USE=microdns is required for Chromecast autodetection support"
+ fi
+}
+
src_prepare() {
default
@@ -272,6 +285,7 @@ src_configure() {
$(use_enable aom)
$(use_enable archive)
$(use_enable bidi fribidi)
+ $(use_enable bidi harfbuzz)
$(use_enable bluray)
$(use_enable cddb libcddb)
$(use_enable chromaprint)
@@ -319,6 +333,7 @@ src_configure() {
$(use_enable lua)
$(use_enable macosx-notifications osx-notifications)
$(use_enable macosx-qtkit)
+ $(use_enable microdns)
$(use_enable modplug mod)
$(use_enable mp3 mad)
$(use_enable mpeg libmpeg2)
@@ -353,7 +368,6 @@ src_configure() {
$(use_enable taglib)
$(use_enable theora)
$(use_enable tremor)
- $(use_enable truetype freetype)
$(use_enable twolame)
$(use_enable udev)
$(use_enable upnp)
@@ -419,7 +433,13 @@ src_configure() {
xdg_environment_reset # bug 608256
- if use truetype || use projectm ; then
+ if use truetype || use bidi; then
+ myeconfargs+=( --enable-freetype )
+ else
+ myeconfargs+=( --disable-freetype )
+ fi
+
+ if use truetype || use projectm; then
local dejavu="/usr/share/fonts/dejavu/"
myeconfargs+=(
--with-default-font=${dejavu}/DejaVuSans.ttf