summaryrefslogtreecommitdiff
path: root/media-video/vlc/vlc-2.2.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-26 20:10:49 +0000
commitc85a90f90521c7e11d618b527d6630cc64cecbd4 (patch)
tree27c1f04d8eab0e0140fb62887a6a5d4d87c32ad9 /media-video/vlc/vlc-2.2.8.ebuild
parent2f51c9978dda4c6e8debca43e4235ecc86914032 (diff)
gentoo resync : 26.12.2017
Diffstat (limited to 'media-video/vlc/vlc-2.2.8.ebuild')
-rw-r--r--media-video/vlc/vlc-2.2.8.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/media-video/vlc/vlc-2.2.8.ebuild b/media-video/vlc/vlc-2.2.8.ebuild
index b7543790bf98..61ec7e46d584 100644
--- a/media-video/vlc/vlc-2.2.8.ebuild
+++ b/media-video/vlc/vlc-2.2.8.ebuild
@@ -37,7 +37,7 @@ IUSE="a52 aalib alsa altivec atmo +audioqueue +avcodec +avformat bidi bluray cdd
macosx-dialog-provider macosx-eyetv macosx-quartztext macosx-qtkit
matroska cpu_flags_x86_mmx modplug mp3 mpeg mtp musepack ncurses neon ogg
omxil opencv opengl optimisememory opus png postproc projectm pulseaudio
- +qt5 rdp rtsp run-as-root samba schroedinger sdl sdl-image sftp shout
+ +qt5 rtsp run-as-root samba schroedinger sdl sdl-image sftp shout
sid skins speex cpu_flags_x86_sse svg +swscale taglib theora tremor truetype
twolame udev upnp vaapi v4l vcdx vdpau vlm vnc vorbis vpx wma-fixed +X
x264 x265 +xcb xml xv zeroconf zvbi
@@ -133,7 +133,6 @@ RDEPEND="
projectm? ( media-libs/libprojectm:0 media-fonts/dejavu:0 )
pulseaudio? ( >=media-sound/pulseaudio-1:0 )
qt5? ( dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5 )
- rdp? ( =net-misc/freerdp-1*:0=[client] )
samba? ( >=net-fs/samba-4.0.0:0[client,-debug(-)] )
schroedinger? ( >=media-libs/schroedinger-1.0.10:0 )
sdl? ( >=media-libs/libsdl-1.2.10:0
@@ -258,8 +257,12 @@ src_configure() {
# Compatibility fix for Samba 4.
use samba && append-cppflags "-I/usr/include/samba-4.0"
- # We need to disable -fstack-check if use >=gcc 4.8.0. bug #499996
- use x86 && append-cflags $(test-flags-CC -fno-stack-check)
+ if use x86; then
+ # We need to disable -fstack-check if use >=gcc 4.8.0. bug #499996
+ append-cflags $(test-flags-CC -fno-stack-check)
+ # Bug 569774
+ replace-flags -Os -O2
+ fi
# FIXME: Needs libresid-builder from libsidplay:2 which is in another directory...
append-ldflags "-L/usr/$(get_libdir)/sidplay/builders/"
@@ -287,6 +290,7 @@ src_configure() {
--disable-dependency-tracking \
--disable-optimizations \
--disable-update-check \
+ --disable-freerdp \
--enable-fast-install \
--enable-screen \
$(use_enable a52) \
@@ -362,7 +366,6 @@ src_configure() {
$(use_enable postproc) \
$(use_enable projectm) \
$(use_enable pulseaudio pulse) \
- $(use_enable rdp freerdp) \
$(use_enable rtsp realrtsp) \
$(use_enable run-as-root) \
$(use_enable samba smbclient) \