summaryrefslogtreecommitdiff
path: root/media-video/vlc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-27 09:11:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-27 09:11:36 +0100
commite67c9b35124c5b3338943cf7793fe4402f03ad0f (patch)
treeae666570705e3bb470ce37171e065978b46063f5 /media-video/vlc/files
parent9e68aee0e16e4b361fe06f9566c74b4bb2a22a27 (diff)
gentoo auto-resync : 27:05:2023 - 09:11:36
Diffstat (limited to 'media-video/vlc/files')
-rw-r--r--media-video/vlc/files/vlc-9999-configure-lua-version.patch (renamed from media-video/vlc/files/vlc-configure_lua_version.patch)17
-rw-r--r--media-video/vlc/files/vlc-9999-fix-libtremor-libs.patch11
2 files changed, 17 insertions, 11 deletions
diff --git a/media-video/vlc/files/vlc-configure_lua_version.patch b/media-video/vlc/files/vlc-9999-configure-lua-version.patch
index 2628075535a6..223841de8a3c 100644
--- a/media-video/vlc/files/vlc-configure_lua_version.patch
+++ b/media-video/vlc/files/vlc-9999-configure-lua-version.patch
@@ -1,10 +1,6 @@
-Only look for one single version of Lua: the one pointed to by the
-pkgconfig package 'lua'. The wrapper set up by lua eclasses will take care
-of the rest.
-
---- a/configure.ac 2021-06-11 12:20:01.222417096 +0200
-+++ b/configure.ac 2021-06-11 12:21:00.257419197 +0200
-@@ -1907,44 +1907,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1847,43 +1847,10 @@ AC_ARG_ENABLE([lua],
[disable LUA scripting support (default enabled)]))
if test "${enable_lua}" != "no"
then
@@ -45,11 +41,10 @@ of the rest.
- AS_IF([test "${have_lua_lib}" = "yes"], [
- AC_CHECK_HEADERS([lua.h lauxlib.h lualib.h], [ have_lua=yes ], []) ])
- ])
--
+ PKG_CHECK_MODULES(LUA, lua,
+ [ have_lua=yes ],
+ [ have_lua=no ]
-+ )
- if test "x${have_lua}" != "xyes" ; then
++ )
+
+ if test "${have_lua}" != "yes" ; then
AC_MSG_ERROR([Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error.])
- fi
diff --git a/media-video/vlc/files/vlc-9999-fix-libtremor-libs.patch b/media-video/vlc/files/vlc-9999-fix-libtremor-libs.patch
new file mode 100644
index 000000000000..3703cea1f10d
--- /dev/null
+++ b/media-video/vlc/files/vlc-9999-fix-libtremor-libs.patch
@@ -0,0 +1,11 @@
+--- a/modules/codec/Makefile.am
++++ b/modules/codec/Makefile.am
+@@ -332,7 +332,7 @@ codec_LTLIBRARIES += $(LTLIBdaala)
+ libtremor_plugin_la_SOURCES = codec/vorbis.c
+ libtremor_plugin_la_CPPFLAGS = $(AM_CPPFLAGS) -DPLUGIN_TREMOR
+ libtremor_plugin_la_LDFLAGS = $(AM_LDFLAGS) -rpath '$(codecdir)'
+-libtremor_plugin_la_LIBADD = -lvorbisdec -logg
++libtremor_plugin_la_LIBADD = $(VORBIS_LIBS) $(OGG_LIBS)
+ EXTRA_LTLIBRARIES += libtremor_plugin.la
+ codec_LTLIBRARIES += $(LTLIBtremor)
+