summaryrefslogtreecommitdiff
path: root/media-video/vlc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:13:10 +0100
commit0bff53119f08d677db6c1a991bd30741682a8a08 (patch)
tree6ec8d4c38152bb4f2bb4b93277236ebd9fbbd21d /media-video/vlc/files
parent6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (diff)
Revert "gentoo resync : 02.06.2018"
This reverts commit 6c14fa2586d9e9c4427b5f727dc6c8ab77587cec.
Diffstat (limited to 'media-video/vlc/files')
-rw-r--r--media-video/vlc/files/vlc-3.0.1-arm-neon-fix.patch65
-rw-r--r--media-video/vlc/files/vlc-3.0.3-fix-disable-vlm.patch42
2 files changed, 65 insertions, 42 deletions
diff --git a/media-video/vlc/files/vlc-3.0.1-arm-neon-fix.patch b/media-video/vlc/files/vlc-3.0.1-arm-neon-fix.patch
new file mode 100644
index 000000000000..6ea45d5abf0b
--- /dev/null
+++ b/media-video/vlc/files/vlc-3.0.1-arm-neon-fix.patch
@@ -0,0 +1,65 @@
+From: Janne Grunau <janne-vlc@jannau.net>
+Date: Mon, 19 Feb 2018 00:47:53 +0100
+Subject: arm: make the assembler functions compatible with non ELF/gas
+ platforms
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Allow assembling arm neon functions for IOS and arm windows.
+
+Signed-off-by: Martin Storsjö <martin@martin.st>
+(cherry picked from commit ec4d9649d1c03fe8f578db38b41dccdf5e11b005)
+Signed-off-by: Thomas Guillem <thomas@gllm.fr>
+
+[Add modules/arm_neon/asm.S missing from orig tarball.]
+---
+ modules/arm_neon/asm.S | 39 +++++++++++++++++++++++++++++++++++++++
+ 1 file changed, 39 insertions(+)
+ create mode 100644 modules/arm_neon/asm.S
+
+diff --git a/modules/arm_neon/asm.S b/modules/arm_neon/asm.S
+new file mode 100644
+index 0000000..728391e
+--- /dev/null
++++ b/modules/arm_neon/asm.S
+@@ -0,0 +1,39 @@
++/*
++ * Copyright (c) 2018 Janne Grunau <janne-libav@jannau.net>
++ *
++ * This program is free software; you can redistribute it and/or
++ * modify it under the terms of the GNU Lesser General Public
++ * License as published by the Free Software Foundation; either
++ * version 2.1 of the License, or (at your option) any later version.
++ *
++ * This program is distributed in the hope that it will be useful,
++ * but WITHOUT ANY WARRANTY; without even the implied warranty of
++ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++ * Lesser General Public License for more details.
++ *
++ * You should have received a copy of the GNU Lesser General Public
++ * License along with this program; if not, write to the Free Software
++ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
++ */
++
++#ifdef __APPLE__
++# define EXTERN_ASM _
++#else
++# define EXTERN_ASM
++#endif
++
++#if defined(__APPLE__) || defined(_WIN32)
++# define HAVE_AS_ARCH_DIRECTIVE 0
++# define HAVE_AS_FPU_DIRECTIVE 0
++#else
++# define HAVE_AS_ARCH_DIRECTIVE 1
++# define HAVE_AS_FPU_DIRECTIVE 1
++#endif
++
++.macro function name
++ .globl EXTERN_ASM\name
++#ifdef __ELF__
++ .type EXTERN_ASM\name, %function
++#endif
++EXTERN_ASM\name:
++.endm
diff --git a/media-video/vlc/files/vlc-3.0.3-fix-disable-vlm.patch b/media-video/vlc/files/vlc-3.0.3-fix-disable-vlm.patch
deleted file mode 100644
index fe4eecb8e767..000000000000
--- a/media-video/vlc/files/vlc-3.0.3-fix-disable-vlm.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 49450a4ab90bba8530764c5cdb95d648aeda7d52 Mon Sep 17 00:00:00 2001
-From: =?utf8?q?Hugo=20Beauz=C3=A9e-Luyssen?= <hugo@beauzee.fr>
-Date: Mon, 28 May 2018 18:25:15 +0200
-Subject: [PATCH] qt: Fix build with --disable-vlm
-MIME-Version: 1.0
-Content-Type: text/plain; charset=utf8
-Content-Transfer-Encoding: 8bit
-
-Fix #20495
-
-(cherry picked from commit 44a635bd4ae16fec5295f6f8aee4dd2ffd7e97d8)
-Signed-off-by: Hugo Beauzée-Luyssen <hugo@beauzee.fr>
----
- modules/gui/qt/Makefile.am | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/modules/gui/qt/Makefile.am b/modules/gui/qt/Makefile.am
-index cb77b14d96..c67f4afc13 100644
---- a/modules/gui/qt/Makefile.am
-+++ b/modules/gui/qt/Makefile.am
-@@ -191,7 +191,6 @@ nodist_libqt_plugin_la_SOURCES = \
- gui/qt/dialogs/open.moc.cpp \
- gui/qt/dialogs/openurl.moc.cpp \
- gui/qt/dialogs/podcast_configuration.moc.cpp \
-- gui/qt/dialogs/vlm.moc.cpp \
- gui/qt/dialogs/firstrun.moc.cpp \
- gui/qt/dialogs/extensions.moc.cpp \
- gui/qt/dialogs/fingerprintdialog.moc.cpp \
-@@ -445,6 +444,10 @@ EXTRA_DIST += gui/qt/vlc.qrc $(libqt_plugin_la_RES)
-
- nodist_libqt_plugin_la_SOURCES += gui/qt/resources.cpp
-
-+if ENABLE_VLM
-+nodist_libqt_plugin_la_SOURCES += gui/qt/dialogs/vlm.moc.cpp
-+endif
-+
- gui/qt/resources.cpp: gui/qt/vlc.qrc $(libqt_plugin_la_RES)
- $(AM_V_GEN)$(RCC) -name vlc -o $@ $<
-
---
-2.11.0
-