summaryrefslogtreecommitdiff
path: root/media-video/vidcutter/vidcutter-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /media-video/vidcutter/vidcutter-9999.ebuild
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'media-video/vidcutter/vidcutter-9999.ebuild')
-rw-r--r--media-video/vidcutter/vidcutter-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/media-video/vidcutter/vidcutter-9999.ebuild b/media-video/vidcutter/vidcutter-9999.ebuild
index 399c8d2dceb2..8ec68eb7ef9e 100644
--- a/media-video/vidcutter/vidcutter-9999.ebuild
+++ b/media-video/vidcutter/vidcutter-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7,8,9} )
-inherit distutils-r1
+inherit distutils-r1 xdg
DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
@@ -13,7 +13,6 @@ HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter
if [[ ${PV} == 9999 ]];then
inherit git-r3
EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
- KEYWORDS=""
else
SRC_URI="https://github.com/ozmartian/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -27,12 +26,14 @@ DEPEND="
>=media-video/mpv-0.25[libmpv]
"
RDEPEND="${DEPEND}
- >=dev-python/PyQt5-5.7[dbus,multimedia,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-5.7[dbus,multimedia,widgets,${PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
media-video/ffmpeg[X,encode]
media-video/mediainfo"
BDEPEND="
${PYTHON_DEPS}
dev-python/setuptools[${PYTHON_USEDEP}]"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
src_install() {
distutils-r1_src_install