summaryrefslogtreecommitdiff
path: root/media-video/vcsi/vcsi-7.0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 22:36:46 +0100
commit783da4542a9c3e0e1ec703644212707cde610679 (patch)
tree3e0cf56ac37ddf9d5fdc6ff0ced9135b1c7fc5e0 /media-video/vcsi/vcsi-7.0.16.ebuild
parentd0041c590ed45bbfeae458ea926e36bc64e41dd7 (diff)
gentoo auto-resync : 10:09:2023 - 22:36:45
Diffstat (limited to 'media-video/vcsi/vcsi-7.0.16.ebuild')
-rw-r--r--media-video/vcsi/vcsi-7.0.16.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-video/vcsi/vcsi-7.0.16.ebuild b/media-video/vcsi/vcsi-7.0.16.ebuild
new file mode 100644
index 000000000000..8c74d9f5c7f4
--- /dev/null
+++ b/media-video/vcsi/vcsi-7.0.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+MY_COMMIT="a42353ec9b17e2feb964c0f78830b836625cf148"
+
+DESCRIPTION="Create thumbnail sheets from video files"
+HOMEPAGE="https://github.com/amietn/vcsi"
+SRC_URI="https://github.com/amietn/vcsi/archive/${MY_COMMIT}.tar.gz -> ${P}-r1.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ dev-python/pillow[jpeg,truetype,${PYTHON_USEDEP}]
+ dev-python/texttable[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ media-video/ffmpeg"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}"/vcsi-${MY_COMMIT}