summaryrefslogtreecommitdiff
path: root/media-video/ttcut/ttcut-0.19.6_p1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
commita5956e0a0daddcad648e0d8d8e5cb3e49e09bda7 (patch)
tree3d2e0a61f348a5299e73ca7c2b236156a8cc79b5 /media-video/ttcut/ttcut-0.19.6_p1.ebuild
parent38f60b3ec9ff175535d9a056a76ae42931e61e21 (diff)
gentoo resync : 18.11.2017
Diffstat (limited to 'media-video/ttcut/ttcut-0.19.6_p1.ebuild')
-rw-r--r--media-video/ttcut/ttcut-0.19.6_p1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/ttcut/ttcut-0.19.6_p1.ebuild b/media-video/ttcut/ttcut-0.19.6_p1.ebuild
new file mode 100644
index 000000000000..e00e37db471b
--- /dev/null
+++ b/media-video/ttcut/ttcut-0.19.6_p1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils qmake-utils xdg
+
+DESCRIPTION="Tool for cutting MPEG files especially for removing commercials"
+HOMEPAGE="http://www.tritime.de/ttcut/"
+SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libmpeg2-0.4.0
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ virtual/glu
+ virtual/opengl"
+RDEPEND="${DEPEND}
+ media-video/mplayer
+ >=media-video/ffmpeg-1.0.8[encode]"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ eqmake5 ttcut.pro
+}
+
+src_install() {
+ dobin ttcut
+
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ dodoc AUTHORS BUGS CHANGELOG README.* TODO
+}