summaryrefslogtreecommitdiff
path: root/media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild')
-rw-r--r--media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild b/media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild
new file mode 100644
index 000000000000..2ca5c574c244
--- /dev/null
+++ b/media-video/ttcut/ttcut-0.19.6_p1-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils xdg
+
+DESCRIPTION="Tool for cutting MPEG files especially for removing commercials"
+HOMEPAGE="https://github.com/templer/ttcut"
+SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=media-libs/libmpeg2-0.4.0
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ virtual/glu
+ virtual/opengl
+"
+RDEPEND="
+ ${DEPEND}
+ media-video/mplayer
+ >=media-video/ffmpeg-1.0.8[encode]
+"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ xdg_environment_reset
+
+ eqmake5 ttcut.pro
+}
+
+src_install() {
+ dobin ttcut
+
+ domenu "${FILESDIR}"/${PN}.desktop
+
+ dodoc AUTHORS BUGS CHANGELOG README.* TODO
+}